Honored Contributor.. Tom Meier Honored Contributor..
Honored Contributor..
217 views

Change the default agent install dir ( OMW 9.0 ; OA 11.13 )

Jump to solution

Hello,

I want to change the default install dir for agent 11.13 on OMW 9.0 for remote installation.

I want to use the variable %ProgramFiles%.

I tried following in agent_install_defaults.cfg:

 [pmad]

INSTALL_DIR=”%ProgramFiles%\HP\HPBTO\”

Result: on oainstall.log msiexec … INSTALLDIR="%ProgramFiles%\HP\HPBTO""

With 2 “ at the end and it is not working. ( with timeout )

Also I tried INSTALL_DIR=”c:\Program Files\HP\HPBTO\” ( as in online-help )

In ovinstallparams.ini I found INSTALLDIR=c:\Program Files\HP\HPBTO"

With the missing “ on the path beginning.

After this I have to kill the msiexec process on the node.

(With agent 8.60 it worked with INSTALL_DIR=”%ProgramFiles%\HP\HPBTO\”)

How can I change the install dir ?

 

Many thanks

Tom

 

P.S. OMW 9.0 with the latest patch on w2k8 r2 64bit

0 Likes
1 Solution

Accepted Solutions
Honored Contributor.. Tom Meier Honored Contributor..
Honored Contributor..

Re: Change the default agent install dir ( OMW 9.0 ; OA 11.13 )

Jump to solution

Hello Carlos Pinto,

 

I have got the correct answer support.

 

The correct parameter is without quotation marks even if there is a space in the path name.

 

This would be the correct sample:

 

; [pmad]
; ^192.168.<*>:INSTALL_DIR=C:\HPOM Agent
; ^192.168.<*>:DATA_DIR=C:\HPOM Agent Data

 

best regards

 

Tom Meier

View solution in original post

0 Likes
8 Replies
Carlos_Pinto Outstanding Contributor.
Outstanding Contributor.

Re: Change the default agent install dir ( OMW 9.0 ; OA 11.13 )

Jump to solution

Hello Tom Meier,

 

Per online help in the support document "Specify folders for remote agent installation"

 

The following it's mentioned:

 

To specify folders for remote agent installation

Prepare the agent installation defaults file, as described in the topic Configure HTTPS agent installation defaults.

 

On a new line in the agent installation defaults file, type the following namespace:

 

[pmad]

 

Under the pmad namespace add the following parameters on separate lines:

 

INSTALL_DIR="<installation_folder>"

DATA_DIR="<data_folder>"

 

Optional. Specify the node or nodes to which the management server should use the folder settings. Prefix each parameter with a pattern that matches one or more node names or IP addresses. Use standard HPOM pattern syntax.

 

Please make sure this is configure correctly.

 

Also please consult the following thread:

 

http://h30499.www3.hp.com/t5/Systems-Management-OpenView-OP/Change-default-drive-for-Windows-agent/td-p/4786287#.U3TwUvldWHc

 

Which mentions:

 

-- Begin Paste --

1- Copy the file:

\conf\PMAD\agent_install_defaults.cfg.sample

 

to:

 

\conf\PMAD\agent_install_defaults.cfg

 

2- Open the new file in a text editor.

 

3- On a new line in the agent installation defaults file, type the following namespace:

 

[pmad]

 

4- Under the pmad namespace add the following parameters on separate lines:

 

INSTALL_DIR=""

DATA_DIR=""

 

This will apply to any push installation which may impact your Unix clients, so its preferred to use pattern matching for a certain nodes by the below steps

 

4- (or) Specify the node or nodes to which the management server should use the folder settings. Prefix each parameter with a pattern that matches one or more node names or IP addresses. Use standard HPOM pattern syntax.

Type a colon (:) at the end of the pattern.

 

[pmad]

^192.168.<*>:INSTALL_DIR="C:\HP Operations Agent"

^192.168.<*>:DATA_DIR="C:\HP Operations Agent Data"

 

The above example specifies the following folders for remote agent installation on nodes with IP addresses that begin 192.168.*

 

Installation folder: C:\HP Operations Agent

Data folder: C:\HP Operations Agent Data

On nodes with any other IP addresses, the management server installs the agents using the default folders.

 

-- End Paste --

 

 

Hope this information helps.

 

Thanks and Regards,

Carlos Pinto

 

HP Support 

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution

If you liked it I would appreciate KUDOs

Carlos Pinto
0 Likes
Honored Contributor.. Tom Meier Honored Contributor..
Honored Contributor..

Re: Change the default agent install dir ( OMW 9.0 ; OA 11.13 )

Jump to solution

Hello Carlos Pinto,

 

I did it as you described and I wrote it in the post, but this did not work !!!

 

The deployment will end after 1 hour with timeout failure.

 

There is a mismatch with quotation marks.

 

Here the last line in oainstall.log:

0: INF: Fri May 16 12:30:26 2014: oasetup.exe (6104/8276): Installing using the command (msiexec /i HPSharedComp.msi  ZBIGNORECONDITIONS=TRUE /quiet /L*v "C:/Windows/TEMP//oainstaller.log"  REBOOT=ReallySuppress DATADIR="c:\Program Files\HP\HPBTO\Data"" DEFER_ACTIVATE="FALSE" DEFER_CONFIGURE="TRUE" DISABLE_PERF="FALSE" EVAL_LICENSE="FALSE" FORCE_CONFIG_MODE="TRUE" IFPAINSTALLED="FALSE" INSTALLDIR="c:\Program Files\HP\HPBTO"" PATCHACTIVATEONLY="FALSE" RUNACTIVATE="FALSE" RUNCONFIGURE="TRUE" )

 

There are two quotation marks at the end of datadir and installdir path!!!

 

In ovinstallparams.ini I found these lines:

*************************************************

[ovinstaller.properties]

DATADIR=c:\Program Files\HP\HPBTO\Data"

DATA_DIR=C:\ProgramData

DEFER_ACTIVATE=FALSE

DEFER_CONFIGURE=TRUE

DEFER_INSTALL_NOTIFICATION=TRUE

DISABLE_PERF=FALSE

EVAL_LICENSE=FALSE

FORCE_CONFIG_MODE=TRUE

IFPAINSTALLED=FALSE

INSTALLDIR=c:\Program Files\HP\HPBTO"

INSTALL_DIR=c:\Program Files\HP\HPBTO\Data"

LOGFILE=C:/Windows/TEMP/oainstall.log

PATCHACTIVATEONLY=FALSE

PROFILE_FILE=server_name.profile

RUNACTIVATE=FALSE

RUNCONFIGURE=TRUE

SKIP_ARCHCHECK=TRUE

 ************************************************

Here is a quotation mark missing at the beginning of the path...

 

On the Node I have to kill the process msiexec and this will also end oasetup.exe.

 

Please let me know what I did wrong.

Many thanks

 

Tom

0 Likes
Carlos_Pinto Outstanding Contributor.
Outstanding Contributor.

Re: Change the default agent install dir ( OMW 9.0 ; OA 11.13 )

Jump to solution

Hello Tom Meier,

 

Based on what is mentioned have you tried to fix the "quotation marks" as seen below with the sign >>>.

 

[ovinstaller.properties]

>>> DATADIR="c:\Program Files\HP\HPBTO\Data"

DATA_DIR=C:\ProgramData

DEFER_ACTIVATE=FALSE

DEFER_CONFIGURE=TRUE

DEFER_INSTALL_NOTIFICATION=TRUE

DISABLE_PERF=FALSE

EVAL_LICENSE=FALSE

FORCE_CONFIG_MODE=TRUE

IFPAINSTALLED=FALSE

>>> INSTALLDIR="c:\Program Files\HP\HPBTO"

>>> INSTALL_DIR=c:\Program Files\HP\HPBTO\Data

 

After this action have you tried a new deployment?

 

Hope this helps.

 

Thanks and Regards,

Carlos Pinto

 

HP Support 

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution

If you liked it I would appreciate KUDOs

Carlos Pinto
0 Likes
Honored Contributor.. Tom Meier Honored Contributor..
Honored Contributor..

Re: Change the default agent install dir ( OMW 9.0 ; OA 11.13 )

Jump to solution

Hello Carlos Pinto,

 

because the ovinstallparams.ini file will be first created while deploying the agent I can not motify it.

 

When I try to use these parameter in agent_install_defaults.cfg

 

[pmad]
INSTALL_DIR=c:\HP\HPBTO\
DATA_DIR=c:\HP\HPBTO\Data\

 

the installation will end successfully

 

with no parameters it will use HP default successfully.

 

With parameters having quotation marks like:

[pmad]
INSTALL_DIR="c:\Program Files\HP\HPBTO\"
DATA_DIR="c:\Program Files\HP\HPBTO\Data\"

 

I get only errors...

 

Please verify.

I am using OMW 9.0 with patch omw_00178/omw_00184 and OA 11.13

 

many thanks in advance

 

Tom Meier

0 Likes
Carlos_Pinto Outstanding Contributor.
Outstanding Contributor.

Re: Change the default agent install dir ( OMW 9.0 ; OA 11.13 )

Jump to solution

Hello Tom Meier,

 

You mention that:

 

When I try to use these parameter in agent_install_defaults.cfg

 

[pmad]

INSTALL_DIR=c:\HP\HPBTO\

DATA_DIR=c:\HP\HPBTO\Data\

 

the installation will end successfully

 

with no parameters it will use HP default successfully.

 

With parameters having quotation marks like:

[pmad]

INSTALL_DIR="c:\Program Files\HP\HPBTO\"

DATA_DIR="c:\Program Files\HP\HPBTO\Data\"

 

But per provide sample file on:

 

"C:\ProgramData\HP\HP BTO Software\shared\conf\pmad"

 

Its mentioned that:

 

Specify agent installation and data directories for remote deployment

; -----------------------------------------------------------------------

;

; This sample defines that the HTTPS-based HP Operations Agent must be

; installed into the directory "C:\HPOM Agent" during a remote agent

; deployment on all nodes with the IP address 192.168.* and the agent

; data directory must be "C:\HPOM Agent Data".

;

; [pmad]

; ^192.168.<*>:INSTALL_DIR="C:\HPOM Agent"

; ^192.168.<*>:DATA_DIR="C:\HPOM Agent Data"

;

; Parameter DATA_DIR is supported only by the agent version 8.53 and

; higher.

 

OVPMAD tracing will be required and further testing so in this call unless you have more feedback or better answer a support case could be open for this specific issue.

 

Hope this helps.

 

Thanks and Regards,

Carlos Pinto

      

HP Support 

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution

If you liked it I would appreciate KUDOs

Carlos Pinto
0 Likes
Honored Contributor.. Tom Meier Honored Contributor..
Honored Contributor..

Re: Change the default agent install dir ( OMW 9.0 ; OA 11.13 )

Jump to solution

Hello Carlos Pinto,

 

today I installed omw_00187 on OM Server but got the same failure when deploying the agent.

I now opened a support case.

 

 

Many thanks

 

Tom Meier

0 Likes
Honored Contributor.. Tom Meier Honored Contributor..
Honored Contributor..

Re: Change the default agent install dir ( OMW 9.0 ; OA 11.13 )

Jump to solution

Hello Carlos Pinto,

 

I have got the correct answer support.

 

The correct parameter is without quotation marks even if there is a space in the path name.

 

This would be the correct sample:

 

; [pmad]
; ^192.168.<*>:INSTALL_DIR=C:\HPOM Agent
; ^192.168.<*>:DATA_DIR=C:\HPOM Agent Data

 

best regards

 

Tom Meier

View solution in original post

0 Likes
Carlos_Pinto Outstanding Contributor.
Outstanding Contributor.

Re: Change the default agent install dir ( OMW 9.0 ; OA 11.13 )

Jump to solution

Hello Tom Meier,

 

Thanks for the last post and confirm that now it's all fine.

 

Hope this helps.

 

Thanks and Regards,

Carlos Pinto

      

HP Support 

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution

If you liked it I would appreciate KUDOs

Carlos Pinto
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.