Highlighted
New Member.
268 views

Messages not coming to management server

Jump to solution
  • Firewall ports open both sides. Verified this. bbcutil works from both ends
  • All agents are running.
  • node added to appropriate node group & responsibility matrix
  • System.txt doesn't show any error
  • Policy condition working fine as seen in trace file.
  • Enabled trace. Trace file shows the message id generated for a policy condition. But that message doesn't show up on management server

Trace entries:

 

09/09 08:25:18.997 opcle(5824:4912)[msg]: Sending message: 5c7e2c50-381c-71e4-063e-876b43d30000 

 

09/09 08:25:18.997 opcmsga(2060:5492)[msg]: Message/Act.Resp. received from agents: 5c7e2c50-381c-71e4-063e-876b43d30000 

 

09/09 08:25:18.997 opcle(5824:4912)[init]: Event 'OpcMessageInMsgQ' -> 'Global\OpcMessageInMsgQ'.
09/09 08:25:18.997 opcle(5824:4912)[init]: Trying to set the event Global\OpcMessageInMsgQ
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: MSGA: MsgThd: checking queue
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: MSGA: Checking queue status of 'C:\ProgramData\HP\HP BTO Software\tmp\OpC\msgagtq' (Err.sent: 0) ...
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: Locking queue: C:\ProgramData\HP\HP BTO Software\tmp\OpC\msgagtq.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: lread_from_pos. pos = 0. len = 36. read 36 bytes.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: Unlocked queue: C:\ProgramData\HP\HP BTO Software\tmp\OpC\msgagtq.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: Got status of Q 'C:\ProgramData\HP\HP BTO Software\tmp\OpC\msgagtq': 0. Rc: 0.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: MSGA: Queue is OK.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: Locking queue: C:\ProgramData\HP\HP BTO Software\tmp\OpC\msgagtq.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: lread_from_pos. pos = 0. len = 36. read 36 bytes.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: Reading queue 'C:\ProgramData\HP\HP BTO Software\tmp\OpC\msgagtq'(7).
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: check header. header = 180506, 178120, 177935, 1
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: lread_from_pos. pos = 178120. len = 8. read 8 bytes.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: read qe header values: size = 2378, tag = 155 from pos = 178120
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: Return buffer too small. Is: 2048; Need: 2378.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: Unlocked queue: C:\ProgramData\HP\HP BTO Software\tmp\OpC\msgagtq.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: Locking queue: C:\ProgramData\HP\HP BTO Software\tmp\OpC\msgagtq.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: lread_from_pos. pos = 0. len = 36. read 36 bytes.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: Reading queue 'C:\ProgramData\HP\HP BTO Software\tmp\OpC\msgagtq'(7).
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: check header. header = 180506, 178120, 177935, 1
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: lread_from_pos. pos = 178120. len = 8. read 8 bytes.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: read qe header values: size = 2378, tag = 155 from pos = 178120
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: lread_from_pos. pos = 178128. len = 2378. read 2378 bytes.
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: write_to_pos. pos = 0. len = 36
09/09 08:25:18.997 opcmsga(2060:5492)[debug]: QM: Unlocked queue: C:\ProgramData\HP\HP BTO Software\tmp\OpC\msgagtq.
09/09 08:25:18.997 opcmsga(2060:5492)[msg]: Message/Act.Resp. received from agents: 5c7e2c50-381c-71e4-063e-876b43d30000 OS

 

Still no messages in the browser / management server.

 

 

Agent  11.13 on Windows 2008 R2

 

Management server - OML 9.11

 

Appreciate any help in this regard

 

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
New Member.

Re: Messages not coming to management server

Jump to solution

Hi Karthik

 

Thanks for the trace files

 

Message is generated from the policy TE-CUSTOM-B2BTEST-EDI

 

Trace snapshot

 

09/09 08:25:18.997 opcle(5824:4912)[debug]: PERF: Starting condition evaluation for template 'TE-CUSTOM-B2BTEST-EDI' (Timer: 10489)
09/09 08:25:18.997 opcle(5824:4912)[debug]: PERF: Testing condition 1 'PORTS NOT ACTIVE' (Timer: 10489)
09/09 08:25:18.997 opcle(5824:4912)[debug]: ATTR: set type 0x4000000 id 9
09/09 08:25:18.997 opcle(5824:4912)[debug]: ATTR: set type 0x12000000 name condition_name
09/09 08:25:18.997 opcle(5824:4912)[debug]: PERF: Matched condition 1 (message condition). Complete. (Timer: 10489)
09/09 08:25:18.997 opcle(5824:4912)[msg]: autoaction node.net_type=1
09/09 08:25:18.997 opcle(5824:4912)[debug]: UUID: created uuid 5c7e2c50-381c-71e4-063e-876b43d30000.

09/09 08:25:18.997 opcle(5824:4912)[msg]: Sending message: 5c7e2c50-381c-71e4-063e-876b43d30000 OS 'Tue Sep  9 08:25:13 2014:PORTS NOT ACTIVE:::123456789,::: Displaying the output of netstat -an:' 135.107.67.211

(Message written to msgagtq file)

 

Processing by opcmsga

 

09/09 08:25:18.997 opcmsga(2060:5492)[msg]: Message/Act.Resp. received from agents: 5c7e2c50-381c-71e4-063e-876b43d30000 OS 'Tue Sep  9 08:25:13 2014:PORTS NOT ACTIVE:::123456789,::: Displaying the output of netstat -an:' 135.107.67.211

09/09 08:25:18.997 opcmsga(2060:5492)[init]: Out_txt echo 5c7e2c50-381c-71e4-063e-876b43d30000 >> "C:\ProgramData\HP\HP BTO Software\log\b2btestedi.log"
09/09 08:25:18.997 opcmsga(2060:5492)[actn]: Local action request created: Auto 5c7e2c50-381c-71e4-063e-876b43d30000 'echo 5c7e2c50-381c-71e4-063e-876b43d30000 >> "C:\ProgramData\HP\HP BTO Software\log\b2btestedi.log"'

 

 

Auto action to be executed is

echo 5c7e2c50-381c-71e4-063e-876b43d30000 >> "C:\ProgramData\HP\HP BTO Software\log\b2btestedi.log

 

09/09 08:25:18.997 opcmsga(2060:5492)[msg]: Message buffered. Wait for local automatic action before send.: 5c7e2c50-381c-71e4-063e-876b43d30000 OS 'Tue Sep  9 08:25:13 2014:PORTS NOT ACTIVE:::123456789,::: Displaying the output of netstat -an:' 135.107.67.211

( Message is waiting for auto action to be completed before forwarding the same)

 

 

(Action response received)

09/09 08:25:21.914 opcmsga(2060:5492)[actn]: Action response received: Auto 5c7e2c50-381c-71e4-063e-876b43d30000 mgr 

09/09 08:25:21.914 opcmsga(2060:5492)[actn]: Action response for waiting msg received.: 5c7e2c50-381c-71e4-063e-876b43d30000 OS 'Tue Sep  9 08:25:13 2014:PORTS NOT ACTIVE:::123456789,::: Displaying the output of netstat -an:' 135.107.67.211

 

 

 

 

09/09 08:25:21.914 opcmsga(2060:5492)[actn]: Suppress handling of waiting message: 5c7e2c50-381c-71e4-063e-876b43d30000 OS 'Tue Sep  9 08:25:13 2014:PORTS NOT ACTIVE:::123456789,::: Displaying the output of netstat -an:' 135.107.67.211

 

(Message is suppressed here instead of being forwarded to OM server)

Please check the auto action window in your policy. I guess option there may be this

"Send message only when auto action fails"

Here auto action is succeeded. Hence message got suppressed

 

 

09/09 08:25:21.914 opcmsga(2060:5492)[actn]: Suppress handling of waiting message: 5c7e2c50-381c-71e4-063e-876b43d30000 OS 'Tue Sep 9 08:25:13 2014:PORTS NOT ACTIVE:::123456789,::: Displaying the output of netstat -an:' 135.107.67.211
09/09 08:25:21.914 opcmsga(2060:5492)[actn]: Action response suppressed because msg was not sent to Mgr: Auto 5c7e2c50-381c-71e4-063e-876b43d30000 mgr

 

Let me know if you need any more clarifications

 

 

Regards

Sandeep

View solution in original post

6 Replies
Highlighted
New Member.

Re: Messages not coming to management server

Jump to solution

Hi Karthik Could you you attach the full trace file please? Then I will analyze and get back

 

Regards

Sandeep

0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: Messages not coming to management server

Jump to solution

Please let me know following details please..?

 

Is this happening to a single node or multiple nodes.. ?

Are you getting the agent status from mangement server for this node.. ?

 

If agent communication is working fine from OML mgmt server, probably you can try these steps.

 

Check the primary manager on the ovconfig on node using ovconfget.

 

If primary mgr is configured correctly, try to download and archive the hist messages for this node

 

opchistdwn -node <name> -older 0h -file /tmp/<filename>

 

trigger a test alert again to see if its received on the management server.

 

 

 

 

 

0 Likes
Highlighted
New Member.

Re: Messages not coming to management server

Jump to solution

Here's the trace file...

0 Likes
Highlighted
New Member.

Re: Messages not coming to management server

Jump to solution

Hi Karthik

 

Thanks for the trace files

 

Message is generated from the policy TE-CUSTOM-B2BTEST-EDI

 

Trace snapshot

 

09/09 08:25:18.997 opcle(5824:4912)[debug]: PERF: Starting condition evaluation for template 'TE-CUSTOM-B2BTEST-EDI' (Timer: 10489)
09/09 08:25:18.997 opcle(5824:4912)[debug]: PERF: Testing condition 1 'PORTS NOT ACTIVE' (Timer: 10489)
09/09 08:25:18.997 opcle(5824:4912)[debug]: ATTR: set type 0x4000000 id 9
09/09 08:25:18.997 opcle(5824:4912)[debug]: ATTR: set type 0x12000000 name condition_name
09/09 08:25:18.997 opcle(5824:4912)[debug]: PERF: Matched condition 1 (message condition). Complete. (Timer: 10489)
09/09 08:25:18.997 opcle(5824:4912)[msg]: autoaction node.net_type=1
09/09 08:25:18.997 opcle(5824:4912)[debug]: UUID: created uuid 5c7e2c50-381c-71e4-063e-876b43d30000.

09/09 08:25:18.997 opcle(5824:4912)[msg]: Sending message: 5c7e2c50-381c-71e4-063e-876b43d30000 OS 'Tue Sep  9 08:25:13 2014:PORTS NOT ACTIVE:::123456789,::: Displaying the output of netstat -an:' 135.107.67.211

(Message written to msgagtq file)

 

Processing by opcmsga

 

09/09 08:25:18.997 opcmsga(2060:5492)[msg]: Message/Act.Resp. received from agents: 5c7e2c50-381c-71e4-063e-876b43d30000 OS 'Tue Sep  9 08:25:13 2014:PORTS NOT ACTIVE:::123456789,::: Displaying the output of netstat -an:' 135.107.67.211

09/09 08:25:18.997 opcmsga(2060:5492)[init]: Out_txt echo 5c7e2c50-381c-71e4-063e-876b43d30000 >> "C:\ProgramData\HP\HP BTO Software\log\b2btestedi.log"
09/09 08:25:18.997 opcmsga(2060:5492)[actn]: Local action request created: Auto 5c7e2c50-381c-71e4-063e-876b43d30000 'echo 5c7e2c50-381c-71e4-063e-876b43d30000 >> "C:\ProgramData\HP\HP BTO Software\log\b2btestedi.log"'

 

 

Auto action to be executed is

echo 5c7e2c50-381c-71e4-063e-876b43d30000 >> "C:\ProgramData\HP\HP BTO Software\log\b2btestedi.log

 

09/09 08:25:18.997 opcmsga(2060:5492)[msg]: Message buffered. Wait for local automatic action before send.: 5c7e2c50-381c-71e4-063e-876b43d30000 OS 'Tue Sep  9 08:25:13 2014:PORTS NOT ACTIVE:::123456789,::: Displaying the output of netstat -an:' 135.107.67.211

( Message is waiting for auto action to be completed before forwarding the same)

 

 

(Action response received)

09/09 08:25:21.914 opcmsga(2060:5492)[actn]: Action response received: Auto 5c7e2c50-381c-71e4-063e-876b43d30000 mgr 

09/09 08:25:21.914 opcmsga(2060:5492)[actn]: Action response for waiting msg received.: 5c7e2c50-381c-71e4-063e-876b43d30000 OS 'Tue Sep  9 08:25:13 2014:PORTS NOT ACTIVE:::123456789,::: Displaying the output of netstat -an:' 135.107.67.211

 

 

 

 

09/09 08:25:21.914 opcmsga(2060:5492)[actn]: Suppress handling of waiting message: 5c7e2c50-381c-71e4-063e-876b43d30000 OS 'Tue Sep  9 08:25:13 2014:PORTS NOT ACTIVE:::123456789,::: Displaying the output of netstat -an:' 135.107.67.211

 

(Message is suppressed here instead of being forwarded to OM server)

Please check the auto action window in your policy. I guess option there may be this

"Send message only when auto action fails"

Here auto action is succeeded. Hence message got suppressed

 

 

09/09 08:25:21.914 opcmsga(2060:5492)[actn]: Suppress handling of waiting message: 5c7e2c50-381c-71e4-063e-876b43d30000 OS 'Tue Sep 9 08:25:13 2014:PORTS NOT ACTIVE:::123456789,::: Displaying the output of netstat -an:' 135.107.67.211
09/09 08:25:21.914 opcmsga(2060:5492)[actn]: Action response suppressed because msg was not sent to Mgr: Auto 5c7e2c50-381c-71e4-063e-876b43d30000 mgr

 

Let me know if you need any more clarifications

 

 

Regards

Sandeep

View solution in original post

Highlighted
New Member.

Re: Messages not coming to management server

Jump to solution

Yeah..I had enabled add output as annotation and send message when action finished.

But I had not checked either of the boxes " When successfull or When failed" I enabled both of them and then I started getting the messages...

Thanks...

0 Likes
Highlighted
New Member.

Re: Messages not coming to management server

Jump to solution

Also, i deleted the node from OM database an re-added it.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.