Pinion Honored Contributor.
Honored Contributor.

[OMW support tip] OMW High message queue build-up.

if you are experiencing high number of messages on OMW however no message storm alerts were received.


You have restart the OMW services an hour ago using the vpstat command, but the queue is still high after an hour.


You seen a high no of  events having status of "R - Running"

"Everytime customer encounter this problem and noticed a number of Events/Messages have their Automatic Actions stuck in 'Running' status and this buffer file is now more than 6000KB in size: D:\HP\HPBTOSoftwareData\shared\tmp\buffers\ActRespHdlrBuffer.


You have manually acknowledged these messages but the buffer file hasn't reduced in size.


You can do the following ...

Configure->Server, then select Namespace "Server-based Flexible Management", then turn on "Expert Mode".


Then set the configuration item "Send directly to HTTPS targets" to the value FALSE.


Now the messages/operations to be forwarded will not be sent directly to the target servers but will be

placed first into queues (one queue per target server).


Then dedicated threads (uncoupled from the message queue) will process these queues.


NOTE: make sure that the sizes fro these forwarding queues are configured large enough.


The configuration items are seen in the same tab, look for "Forwarding queue size maximum..."



Tags (1)
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.