Absent Member.. GTrejos7 Absent Member..
Absent Member..
137 views

[ST OMU] Unable to disable message forwarding from OMU 9.x

PROBLEM:

Message forwarding from OMU to OMW has been configured.
Now want to disable this forwarding and modified the following parameters:

ovconfchg -ovrg server -ns opc -set OPC_HTTPS_MSG_FORWARD FALSE
ovconfchg -ovrg server -ns opc -set OPC_DONT_FORW_MSGKEY_ACK FALSE
ovconfchg -ovrg server -ns opc -set OPC_MOM_SEND_OP_ACK FALSE

renamed the msgforw located in /etc/opt/OV/share/conf/OpC/mgmt_sv/respmgrs

and, finally, restarted OM services: opcsv -stop/-start

But the forwarding is still enabled.


CAUSE:

With OMU9 it is not enough to restart opcforwm after making modifications to the msgforw file.



SOLUTION:

With OMU9 it is not enough to restart opcforwm after making modifications to the msgforw file.

First must execute "ovconfchg" to force it to reread its configuration.

Also, the setting OPC_HTTPS_MSG_FORWARD to FALSE does not disable message forwarding.

Setting it to FALSE means you want to use DCE message forwarding which is no longer supported.

This is documented in the following KCS document:

http://support.openview.hp.com/selfsolve/document/KM00911047

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
If you liked it I would appreciate KUDOs.
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.