Highlighted
Absent Member.. GTrejos7 Absent Member..
Absent Member..
102 views

[ST OMU] User can't save the session before exiting OMU Java GUI console

PROBLEM:
In the Operations Manager for Unix (OMU) Java Gui console user can't save the session before exiting Java console.
When click the X in the top corner to exit from the java console, it asks  "Do you want to save your settings", user clicks "yes",
then a message pops up saying "Console session settings not saved.  Configuration file is read-only".
This happens for a particular user only.

CAUSE:

The itoopbrw file doesn’t exist for the user with the issue.

In a trace we can see:

TRACE MSG, 11:05:44 AM, abc.com.OvEmbLayoutParser: Local Itoopbrw configuration file does not exists!
Default configuration will be applied.

 


RESOLUTION:


According to the Java Gui Operator Manual HPOM administrators can use the itoopbrw file to customize the
attributes of the current message browser.
If a message view filter is applied to a message browser when the browser layout is saved,
the message view filter definition is also saved in the itoopbrw file.

The itoopbrw file uses the following syntax:
VERSION "VERSION STRING"
[ACTIVE | HISTORY | PENDING | NAME:"<NAME>"
{"<COLUMN_NAME>" <WIDTH> ["COLUMN_LABEL"]}
{[ALIGN "<COLUMN_NAME>" LEFT | RIGHT | CENTER]}
{[FILTER
[SORT "<COLUMN_NAME>" ASCEND | DESCEND]
[WIN_WIDTH <WINW>]
[WIN_HEIGHT <WINH>]
]


If this file doesn´t exist, the behavior we are seeing can be explained.

This file is usually stored in the following directories:

• Windows 2000, 2003, and XP

C:\Documents and Settings\<user>

• UNIX

/home/<user>


• Solaris
/export/home/<user>


Here is an example of a itoopbrw file:

VERSION 4.0

HISTORY
     "Severity" 15
     "No. of Duplicates" 8 "Dup. "
     "Flags" 15 "SUIAONE"
     "Time Received" 21
     "Node" 18
     "Application" 17
     "Message Group" 15 "MsgGrp"
     "Object" 14
     "Message Text" 11
     "InstructionText" 20
     "document_url" 20
     SORT "Message Text" ASCEND
     ALIGN "Severity" LEFT
     ALIGN "No. of Duplicates" LEFT
     ALIGN "Flags" LEFT
     ALIGN "Time Received" LEFT
     ALIGN "Node" LEFT
     ALIGN "Application" LEFT
     ALIGN "Message Group" LEFT
     ALIGN "Object" LEFT
     ALIGN "Message Text" LEFT
     ALIGN "InstructionText" LEFT
     ALIGN "document_url" LEFT
     WIN_WIDTH 932
     WIN_HEIGHT 391

ACTIVE
     "Severity" 15
     "No. of Duplicates" 8 "Dup. "
     "Flags" 15 "SUIAONE"
     "Time Received" 21
     "Node" 18
     "Application" 17
     "Message Group" 15 "MsgGrp"
     "Object" 14
     "Message Text" 60
     "InstructionText" 20
     SORT "Message Text" ASCEND
     ALIGN "Severity" LEFT
     ALIGN "No. of Duplicates" LEFT
     ALIGN "Flags" LEFT
     ALIGN "Time Received" LEFT
     ALIGN "Node" LEFT
     ALIGN "Application" LEFT
     ALIGN "Message Group" LEFT
     ALIGN "Object" LEFT
     ALIGN "Message Text" LEFT
     ALIGN "InstructionText" LEFT
     WIN_WIDTH 729
     WIN_HEIGHT 391

ACTIVE
     "Severity" 15
     "No. of Duplicates" 8 "Dup. "
     "Flags" 15 "SUIAONE"
     "Time Received" 21
     "Node" 18
     "Application" 17
     "Message Group" 15 "MsgGrp"
     "Object" 14
     "Message Text" 60
     "InstructionText" 20
     SORT "Message Text" ASCEND
     ALIGN "Severity" LEFT
     ALIGN "No. of Duplicates" LEFT
     ALIGN "Flags" LEFT
     ALIGN "Time Received" LEFT
     ALIGN "Node" LEFT
     ALIGN "Application" LEFT
     ALIGN "Message Group" LEFT
     ALIGN "Object" LEFT
     ALIGN "Message Text" LEFT
     ALIGN "InstructionText" LEFT
     WIN_WIDTH 729
     WIN_HEIGHT 391

 

Creating this file for the user having this issue solves the problem.

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
If you liked it I would appreciate KUDOs.
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.