Highlighted
Absent Member.. GTrejos7 Absent Member..
Absent Member..
129 views

[Support Tip] OMU agent 11 installation in Windows agent fails with error C++ Runtime error

OMU agent 11 installation issue in the Windows 2003 server getting C++ Runtime error while trying to install the OMU agent.

Operating system    :    Windows
OMU Agent version    :    11.xx
 
This error usually shows up when a previous installation has failed and the components have not been removed completely.
If a previous version of the agent has been installed and not removed completely then use the oacleanall script from the 11.x agent
installation patch to cleanup the system before installing Agent 11.

For Windows the following scripts can be found:

Itanium   cscript oacleanall_Windows_IA64.vbs
x86        cscript oacleanall_Windows_X86.vbs
x64        cscript oacleanall_Windows_X64.vbs
 
The appropriate script should be chosen according to the Windows agent architecture
 
According to the installation guide:   

 
This script removes the agent (11.x) from the system completely and
irrecoverably. Use this script only to reverse the effect of an incomplete, unsuccessful, or
incorrect installation of the agent.

Please take into account that is other HP software components are installed (such as HP  Performance Agent) they will be removed as well.
 
On the agent this script can be found in the following path:
 
c:\cscript /opt/OV/bin/OpC/agtinstall/oacleanall_Windows_IA64.vbs

If the agent is not installed then you can copy the binaries from the Management Server in the following path:
 

/opt/OV/bin/OpC/agtinstall/oacleanall_Windows_IA64.vbs


After this the installation can be tried once again.
If still no positive results a manual installation of the agent is the following step as a work around:

The command and procedure are as follows.

The msi packages has to be installed in the below order.

HPOvXpl
HPOvSecCo
HPOvBbc
HPOvCtrl
HPOvDepl
HPOvConf
HPOvPacc
HPOvPerfMI
HPOvPerfAgt
HPOvAgtLc
HPOvEaAgt

The command to install the packages would be:
msiexec /i HPOvXpl.msi /l* C:\temp\HPOvXpl.txt

msiexec /i HPOvSecCo.msi /l* C:\temp\HPOvSecCo.txt

msiexec /i HPOvBbc.msi /l* C:\temp\HPOvBbc.txt

Once the installation is complete with configure script failures, the configure scripts for each of the module in : %ovinstalldir%lbin\configure\<module>\configure.vbs should be executed.

The order of execution of configure.vbs for various modules is :

HPOvXpl
HPOvSecCo
HPOvBbc
HPOvSecCC
HPOvCtrl
HPOvDepl
HPOvConf
HPOvPacc
HPOvPerfMI
HPOVPerfAgt
HPOvPerlA
HPOvAgtLc
HPOvEaAgt
HPOvOpsAg

Also Mamagement Server and certificate server is not set for the node

We set Management Server and certificate server by executing the following:
%OvInstallDir%bin\ OpC\install\oasetup -configure -activateonly -management_server <management_server> -certificate_server <certificate_server>

This should complete the agent installation on the Windows node.




HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
If you liked it I would appreciate KUDOs.
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.