Highlighted
Micro Focus Contributor
Micro Focus Contributor
215 views

[Support tip] - Error message 'couldn't set locale correctly' appears in the admin UI.

After Admin UI installation of HPOM 9.10 on Solaris 10, the message 'couldn't set locale correctly' appears when trying to access the admin UI.

 

To solve this, Make sure that the following UTF-8 locale is installed and configured on the system:

 

- On HP-UX: en_US.utf8

- On Linux and Sun Solaris: en_US.UTF-8

 

After verifying that the system haves the correct locale installed and configured, configure HPOM to use it by setting up the LANG and LC_ALL server configuration variables in the ctrl.env name space.

 

For example, for an English language environment, run the following commands:

 

- On HP-UX:

# ovconfchg -ns ctrl.env -set LANG en_US.utf8

# ovconfchg -ns ctrl.env -set LC_ALL en_US.utf8

 

- On Linux and Sun Solaris:

# ovconfchg -ns ctrl.env -set LANG en_US.UTF-8

# ovconfchg -ns ctrl.env -set LC_ALL en_US.UTF-8

 

Keep in mind that the en_US.utf8 (on HP-UX) or en_US.UTF-8 (on Linux and Sun Solaris) locale must be installed even if other UTF-8 locales are already installed.

 
Alex Herrera
OMU support
TSIA Certified Support Professional (Chris Reed)
aleherma@hp.com

HP Software values your feedback regarding your overall Support experience. Contact us at software.satisfaction@hp.com or my manager directly.



The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.