Bob Dube Absent Member.
Absent Member.
187 views

Quick Test Professional 9.5

Hi,
I am Bob. ABout 6 years ago I was using Mercury's Test Director and WinRunner to automate our test cases. It worked but barely, and was very frustrating. Now am I using Quick Test. Tried a evel copy of Quality Center (Test Director) but it caused to many problems.
Obviously one cannot just stick HP on to a product that had limitations (to be kind) and expect it to be any better. I am actually surprised that HP puts HP in front of these products. Nevertheless, I am stuck with it.
It has been about 2 months now and I had been compiling a list: Top 10 reasons Quick Test (again, to be kind). That list now has 12 items. Here are a few (not in order of suffering):
1) Navigate & Learn can take an hour to learn everything on a page. I use selection most of the time but now and then I need to capture everything on a page.
2) This has happened at least 5 times...while working on a test script I go to save it. The "*" by the name blinks but does not go away. It refuses to save my work. I have been able to save to a new name, and then delete the old and rename the new to the old, but that usually means losing data. I spent an hour today re-entering an Action I worked on yesterday.
3) ABout 10% of the time it will not Record. I acts like it is but as I go through our app nothing is recorded. Usaully a reboot of the system recovers from this, but that also means I have to spend 30 minutes getting everything (not just QT) back up and running.
4) I have saved scripts before and upon re-opening them nothing is there.
5) Saving a test will give an error message box stating "General Error". What the heck is that? Is it general because it happens so often? Is it general because you have no idea of what is going on? If it is "General" you should be able to correct it. Nevertheless, more data and time lost.
6)QT hangs with Not Responding now and then.
7)I have opened a existing test case and QT says it is locked and will only be opened in R/O mode. I am the only one working on this here. ANother reboot.
8)Resources shows ActionX, Test Flow does not show it. I can display it in Expert View but when the entire test is run it is not.

Other notes: while going through the Tours tutorial it says after like every third step to Save the Test. Now I know why, you'll lose less.
Searching on Quick Test, QTP, QuickTest Professional on the HP web site returns nothing. I can almost understand that.

Where can I see a list of reported bugs, and fixes so I can at least have the sense of security (false or not) that this stuff is supported.

Let me say, I really do enjoy working with automation, even QTP can be fun. But I never know when I am going to lose work, or run into countless other problems that affect my schedule.

Comments?

Bob Dube
Insight
0 Likes
5 Replies
Highlighted
Dharmeshkumar V Absent Member.
Absent Member.

Re: Quick Test Professional 9.5

I agree Bob, there is a room to improve QTP
0 Likes
papachong_1 Absent Member.
Absent Member.

Re: Quick Test Professional 9.5

very very good customer,,but, a little pity. HPer haven't see it.
0 Likes
Henry Floyd Absent Member.
Absent Member.

Re: Quick Test Professional 9.5

Bob,

While I agree with you that all software can be improved most of your problems actually have a solution.

1) I have never tried to lean every object on a page. You don't need too. Only use the object you need in your script.

2)What version of QC and QTP are you using. This only happen to me once a year.

3)Usually to fix this problem, you only need QTP to start open the browser. Stop the script and then start recording.

4) I have never had this problem, how did you set up QC and ATP?

5 & 6) Do you have the latest patches?

7) more then likely you have made a modification to the script in QC and then opened the script. First make the QC mod to the test then click on another test to save the changes in QC. Then go back to the test and open the script.

😎 Don't know this one



Anyway I would strongly suggest you find an expert and have him/her show how they would use the product for a day. You probably would save yourself many hours of frustration and headaches just with that one of mentoring.
0 Likes
Håkan Mannela Absent Member.
Absent Member.

Re: Quick Test Professional 9.5

Hello. I have failed to play back simple browser.back actions like:
Browser("whatever").Page("whatever").Link("anything").Click
Browser("whatever").Back

The two lines ARE actually recorded and seems to be ok.
BUT when I try to play it back I get a Run Error popped up in my face.
It says General run error.
Line (2): "Browser("whatever").Back".

Anyone, with experience of this?
Any solution, patch, explanation?

BR /Hakan M
It´s nice to be important, but it´s more important to be nice!
0 Likes
pjacobsma Absent Member.
Absent Member.

Re: Quick Test Professional 9.5

Getting General run error when QTP 9.5 tries to use the back button on IE 7. Anybody got a workaround for this?
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.