Highlighted
SanjeevAgarwal
New Member.
106 views

Unable to run UFT script from ALM Test lab

I am trying to establish connectivity between HPALM 12.5 and UFT 12.53 I have done the HP Connectivity in HPALM and ALM Connectivity in the UFT. We use Crosslink to connect to client network.

While running the Test from ALM Test Lab(Run on Local option) I get the error 'You cannot use the current test. A Unified Functional Testing license is needed. ' My machine has UFT installed with concurrent license. Individually both ALM and UFT works fine. 

On trying to execute the same scripts multiple time, getting different errors as below:

1) Unified Functional Testing error: You cannot use the current test. A Unified Functional Testing license is needed. 

Load the license and try again

2) Unified Functional Testing error: Unable to open the business component in the testing tool.

Error from Unified Functional Testing: The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state

3) Unified Functional Testing error: Unable to open the testing tool.

Error from Unified Functional Testing: There was an error reading from the pipe: The pipe has been ended. (109, 0x6d)

I also tried to run script from ALM after keeping UFT open, ALM closed the UFT and test failed error "Failed to launch application"

Any help on solving the issue will be highly appreciated.

 

Thank You!

 

0 Likes
1 Reply
Micro Focus Contributor
Micro Focus Contributor

Re: Unable to run UFT script from ALM Test lab

Hello Sanjeev

For the error 1, as a workaround, please grant to "Users" group, "Full Control" permissions on "HKLM\SOFTWARE\Wow6432Node\Mercury Interactive\QuickTest Professional\MicTest".

For error 2, are you using Jenkins? What about if you try a connection between ALM and UFT without using Jenkings?

Error 3, looks like this is more related with a test itselft. You can see this external link as a reference.

https://stackoverflow.com/questions/15836199/wcf-namedpipe-communicationexception-the-pipe-has-been-ended-109-0x6d

Please let us know if you have another question.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.