Highlighted
Absent Member.. Absent Member..
Absent Member..
165 views

Cannot switch to UFT when running a test from ALM

Jump to solution

Hi

 

When running a test from ALM, UFT runs in "hidden" mode.  I can get the tooltip saying "click here to open UFT whilst it is running", but UFT will not appear when you click on the tooltip.  This never used to happen with QTP.

 

This is really annoying - if a test stalls for some reason whilst running from ALM, I want to be able to look at UFT to try and see why it's hanging.  Instead, I end up killing the test run.

 

Has anyone esle seen this issue?

 

Cheers

 

Dave

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: Cannot switch to UFT when running a test from ALM

Jump to solution

Hi Dave2000.

 

Hope you are doing well.

 

My name is Ruddy and i want to help you in this issue.

 

Do you want to run always UFT in normal mode or after click the tooltip?

 

If not just unchecked the option to run qtp in hidden mode under remote agent settings.

 

I'll be waiting your answer!

 

Please mark this answer as accepted solution or correct answer if this answered your question.

 

Best regards,

Ruddy Alvarez H.
Customer Support Engineer

If you find thst aat this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the pond show your appreciation.

View solution in original post

0 Likes
4 Replies
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: Cannot switch to UFT when running a test from ALM

Jump to solution

Hi Dave2000.

 

Hope you are doing well.

 

My name is Ruddy and i want to help you in this issue.

 

Do you want to run always UFT in normal mode or after click the tooltip?

 

If not just unchecked the option to run qtp in hidden mode under remote agent settings.

 

I'll be waiting your answer!

 

Please mark this answer as accepted solution or correct answer if this answered your question.

 

Best regards,

Ruddy Alvarez H.
Customer Support Engineer

If you find thst aat this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the pond show your appreciation.

View solution in original post

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Cannot switch to UFT when running a test from ALM

Jump to solution

Hi,
The problem, I guess, is not UFT not showing up when you click the tooltip, but is UFT not responding for some reason while that test execution... 

- Is the issue dependant on that specific script?
- Can be reproduced the hang if you open the test from UFT > Connect to ALM  > And start the test execution?
- If you create a simple test (That only contains wait + msgBox statments) and save it in ALM, can the issue be seen?

 

 

"HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution."
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Cannot switch to UFT when running a test from ALM

Jump to solution

Hi Ruddy

 

I have changed the setting (unchecking the hidden mode) in the remote agent dialog.

 

This gets around my issue nicely.  It doesn't explain why I can't get UFT to appear when clicking the "Show UFT" tooltip, but for some things life's too short.

 

Thanks

 

Dave

0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: Cannot switch to UFT when running a test from ALM

Jump to solution

Hi Dave,

 

The reason i think is just because the developers make it by default but that option allow to change it.

 

Nice to hear that this solutions was helpfull.

 

Have a great week.

 

Best Regards.

Ruddy Alvarez H.
Customer Support Engineer

If you find thst aat this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the pond show your appreciation.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.