Highlighted
Absent Member.
Absent Member.
884 views

Error window on debugging

In UFT when we try to Debug the script i am getting an error message and i am unable to continue with any of the further actions.

Can you please let us know the root cause and solution for this.

Please find the screenshot for the error attached.

 

Note:

The error start like below

System.ComponentModel.Win32Exception (0x80004005): Invalid window handle

at MS.Win32.UnsafeNativeMethods.GetWindowText(HandleRef hWnd, StringBuilder lpString, Int32 nMaxCount)

at System.Windows.Automation.Peers.WindowAutomationPeer.GetNameCore()

at System.Windows.Automation.Peers.AutomationPeer.UpdateSubtree()

0 Likes
3 Replies
Highlighted
Respected Contributor.
Respected Contributor.

 

Hi Senthil,

It's look like parameter error. Could you please check your parameter?
Even if it not solved. Hope, you was recorded Flight Application. So, can you paste your script here?

Thanks,

Sakthi.K


 

If you find that this or any post resolves your issue,
please be sure to mark it as an accepted solution and give Kudos to the author for their assistance.

Regards,
Sakthirajan Kathirvel
0 Likes
Highlighted
Absent Member.
Absent Member.

Hi Sakthirajan,

Thanks for the update. We are getting this error message not only for flight application, but for other applications too.

Also to be noted, we have script for our application and its working in one location. But since we had recent location movement, we installed UFT 12.52 in our new location. And here while debugging the script, we are getting this "Unexpected Error" issue.

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Senthil,

Please check below things,

1. If you are using Object Repository, then check again it's properly import from old script to new script(shared object repository, new location).
2. If you have Utilities functions, check those connections with script.
3. If you are passing inputs from excel sheet then check connection of excel(location of sheet and format)
4. Finally, Turn off your anti virus and execute the script in administrator mode.

Thanks,

Sakthi.K


If you find that this or any post resolves your issue,
please be sure to mark it as an accepted solution and give Kudos to the author for their assistance.

Regards,
Sakthirajan Kathirvel
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.