New Ranks & Badges For The Community!
Notice something different? The ranks and associated badges have gone "Star Fleet". See what they all mean HERE
Absent Member.. Absent Member..
Absent Member..
1136 views

Getting HWND for Chrome browser using UFT 12

I am currently working on updating a function library script to ensure compatibility of our testing scripts with Chrome browser. We are using Chrome version 37 and I have already installed the suggested patch as per the version matrix provided by HP:

 

https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM1312694

 

The code we currently use to get the HWND handle value for the browser window is:

 

Environment.Value("BrowserHwnd") = BrowserObjects(ix).GetRoProperty("hwnd") 
BrowserID = "hwnd:=" & Environment.Value("BrowserHwnd")

 

When I run this using IE, it runs fine and there is a value assigned to hwnd but when using Chrome, the hwnd value is returned as 0. Is there something else that needs to be done or anything special that I am missing that I need to incorporate here in order to get the hwnd for Chrome?

0 Likes
0 Replies
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.