Highlighted
Established Member..
Established Member..
4077 views

How to configure UFT replay speed when test is run from ALM

Hello, I've an UFT script which is running fine when I run it locally from my UFT host.

 

When I run it from ALM, the replay is faster and UFT try to execute steps whithout waiting for application objects to be available.
Because of this, the replay from ALM often fail.

 

How can I configure the speed at which test are executed when run from ALM ?

I alerady checked on uft test settings and on remote agent settings but without success.

 

thanks and kind regards

0 Likes
9 Replies
Highlighted
Absent Member.
Absent Member.

Ideally , you should handle this with synchronization through your script.

 

Ex: waitProperty , Exist , Sync ...

0 Likes
Highlighted
Established Member..
Established Member..

Yes, I could do in this way, but I should restart coding on all my script.

 

My point is that the scripts are already working when I run them on UFT, but when they are replayed from alm, they run differently (faster).

 

I suppose there's a way to configure the run behaviour (or test settings) of the test when run from ALM, am I wrong?

0 Likes
Highlighted
New Member.

For now, you can change the run mode to normal using QTP AOM. Insert this code in your start of trigger/driver script.

 

set qtApp = GetObject("", "QuickTest.Application")
qtApp.Options.Run.RunMode = "Normal"

 

But like RP_test said, tests should run irrespective of execution mode. Effective synchronization should be implemented as part of your code.

 

Thanks...

Accept as solution/Give Kudos to the author if the piece of information answered/helped you to solve your problem.
All the thoughts here are mine not related to my employer nor anyone.
Test Automation Ecstasy
Highlighted
Absent Member.
Absent Member.

I think he is running through ALM , so AOM won't be possible.

0 Likes
Highlighted
Established Member..
Established Member..

I've a question on the code you posted; I tested it and it actually sets runmode = Normal in UFT, but but the runmode used for the current run is the one set at the beginning of the test

 

Example:

Execution from UFT
- I've UFT with runmode = Fast
- I run the script that contains the above code and Runmode is set to Normal, but current test is executed in Fast Mode

Execution from ALM

- I run the script, it actually set UFT runmode as Normal, but the test is executed in fast mode, regardless of what is set on UFT runmode

 

Is there a way to set runmode and execute the test with the runmode just set? In other word, is it possible to change runmode once the test has starder?

 


I agree that tests should run irrespective of execution mode, but in this particular case I've several scripts ready and I'm in a rush to execute them.
I'll fix them later on inserting sync, waitproperty etc

 

thanks and kind regards

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

What version of UFT and what version of ALM are you using?

 

I remember something about ALM ignoring the RunMode setting that was set in the properties of a test in QTP. There was something else that had to be done. I'm trying to find the info now...

[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
Highlighted
Regular Contributor.. Regular Contributor..
Regular Contributor..

Add RunInFastMode=0 to the end of the mic.ini configuration file.

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

or use for "Normal":

Setting.Item("RunMode") = 1

 

and back to fast:

Setting.Item("RunMode") = 0

right at the beginning of your script e.g. the first line

0 Likes
Highlighted
Account_Closed
Not applicable

That feature does not work right in version 14.03. When you run the code the first time, there is no change in the run mode. But when you run it a second time, the run mode changes. So, it does not work for changing the speed on the fly. If anyone else has any ideas, please chime in. --Thomas

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.