Absent Member.. Absent Member..
Absent Member..
286 views

Making certain version of the code file to be used for execution

We have two teams.
1.Coding team and exectuion team

The coding team checks in different versions of the library regularly into ALM and we have weekly releases of automated test cases.


The execution team wants to use 1.5 version where as the last code check in version is 1.9.

 

Is it possible to associate library based on version number to the automated test automatically rather than associating a file.


We want the testers to use 1.5 version of the library rather than 1.9.

 

Is it possible in the context of ALM and QTP? If so ...How ?

 

thanks

0 Likes
1 Reply
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

You can associate everything at runtime. Based on your conditions you can add corresponding repositories, function libraries and data tables.

 

For OR:

Repositories.Collection.Add("Path of tsr file")

 

For Function Library:

ExecuteFile "C:\YourFunctionLibrary.vbs"

or 

LoadFunctionLibrary "C:\YourFunctionLibrary_1.vbs" 'Associate a single function library
LoadFunctionLibrary "C:\FuncLib_1.vbs", "C:\FuncLib_2.vbs" 'Associate more than 1 function libraries

 

Hope this helps.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.