Highlighted
Absent Member.
Absent Member.
188 views

Print command suddenly throws "Wrong Number of arguments" error. V weird.

My collegue and I have been happily using the Print command to send useful information to the Output window for years. Weirdly, this morning we both start working, and for both of us, the Print command suddenly starts throwing the same error whenever we hit in the code:

 

Wrong number of arguments or invalid property assignment: 'Print'

Function file: H:\Projects and Services\PROJECTS\xxxxxxxxxx\UFT_Codebase\Tests\Function Libraries\xxxx_Functions.qfl
Line (359): "                Print vbTab & "Could not open xxxxxxxxxx".

 

This is happening on two seperate physical machines, with two seperate installs of UFT 11.53, across all scripts and involving all Print commands across multiple scripts and function libs. We have not recently patched the installs. It just started happening this morning, out of the blue. I cannot make heads nor tails of this, it doesn't make any sense at all. We are having to go through our code commenting out Print commands just to get it working. This code has been running happily for months without issue.

 

Has anybody else seen anything like this?

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.