halamadrid88 Absent Member.
Absent Member.

QTP 10 .0 - Java Object Identification issues

Hi all,


I have ran into a problem where my QTP 10 which used to run just fine with JAVA objects , all of a sudden seems to be unable to identify them. 

The AUT is a JAVA based standalone application. I have the JAVA Add-in enabled and when spied , all the objects get identified as normal window objects. This is weired because I had no problems with JAVA based objects so far.

I looked into a lot of solutions posted online and tried , but the issue still exists.  I tried changing the JAVA settings from control panel but with no luck. Do I have to modify any environment variables or anything?


Appreciate your inputs!




The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.