Highlighted
Absent Member.
Absent Member.
250 views

QTP 10 and IE

Hi there,

I have QTP installed on my machine. I do have full admin rights.

When I record something IE related, QTP is not taking all the steps I am doing.

Example:

I tell QTP to open the browser and go to a specifig webpage. Thats fine. Then I click a loink on this webpage. Sometimes it gets recorded, sometimes not. The browser buttons like back, forward, stop do always work.

Any ideas what could cause this issue?

The current version is QTP10 from DVD + Patch QTP_00604.EXE

Thanks in advance!

0 Likes
7 Replies
Highlighted
Absent Member.
Absent Member.

Re: QTP 10 and IE

Have you loaded the Web add-in?

Have you disabled tabbed browsing?
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: QTP 10 and IE

Web add-in: yes
Tab browsing: no

I will give it a try. Thank you!
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: QTP 10 and IE

Hi,

There is problem with only web addin, because QTP10.0 is suppor multiple Tab browsing.

Sandip
Regards,
Sandip Gami
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: QTP 10 and IE

Please check Automation--->Record and Run Settings First option ie Record and run test on any open browser .

Please check Web - Add-in has checked in Add-In Manager.


Thanks,
Rajendra
0 Likes
Absent Member.. Absent Member..
Absent Member..

Re: QTP 10 and IE

check with QTP/OS/IE versions. If all are compatible in your PC. Then check with Add-in and Browser settings on security.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: QTP 10 and IE

1.Application should open after QTP
2.Check the BTO add-in is enabled in your machine
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: QTP 10 and IE

For changing Tabs settings. Please follow these things
1. Go to Tools/Internet options
2. General
3. Under TABS - Click settings
4. Check "Enable Tabbed Browsing (requires rewstarting Internet Explorer)
under this
Check "Open Only the first home page when Internet Explorer starts"
5. Select "Your first Home page' in "When a new tab is opened, open:
6. select "Always open pop-ups in a new window" in "Always open pop-ups in a new window"
7. select "A new window" in "open links from other programs in:"
please let me know it works for you
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.