Highlighted
Absent Member.
Absent Member.
1584 views

QTP OR doesnt display test object properties pane

The application i'm working on is web based and addin used is web still my objecty repository doesnt show the object property details in the right pane in name value pair format. doesn't even show the right pane like normally it would be a table. Instead shows blank.

can any one suggest why does this happen????

Thanks,
Priyan

0 Likes
8 Replies
Highlighted
Absent Member.
Absent Member.

Please provide your environment details i.e., Which version of QTP, version of browser and operating system you are using. 

 

Also in your web-App is there any additional technology being used like flex , silverlight etc???

 

0 Likes
Highlighted
Absent Member.
Absent Member.

Hi Priyan,

 

In addition, could you please show some screenshot of the problem?

Is it observed with any object from your AUT? What if you try to reproce problem against Google page for exmaple?

Is this observed for all your tests?

 

Regards,

Ana

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
Highlighted
Absent Member.
Absent Member.

If the object properties are visible in the object spy and not in the object repository properties, then multiple objects are matching the properties. To avoid this, you need to use regular expressions or have only the appropriate page(object) open.

 

+pavan

0 Likes
Highlighted
Absent Member.
Absent Member.

Hello Priyan,

 

If the problem is observed for all test objects in OR and on a specific machine only, you could also try the following:

  1. Close QTP/UFT;

  2. Navigate to registry (type regedit in Start->Run);

  3. Rename (or delete) the HKEY_CURRENT_USER\Software\Mercury Interactive\QuickTest Professional folder. For example, type "_old" after QuickTest Proffesional, i.e. it would look like HKEY_CURRENT_USER\Software\Mercury Interactive\QuickTest Professional_old

  4. Navigate to Start->Run-> %appdata% -> HP and rename (or delete) the QuickTest Professional folder to, for example, QuickTest Professional_old (the new name, as in above item 3, does not really matter, it just has to be different from the default “QuickTest Professional”)

  5. Open QTP/UFT and check the problem. Opening QTP/UFT would create new QuickTest Professional folders in above locations (items 3 & 4) with relevant data.

 

Regards,

Ana

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
Highlighted
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Above option is not working. Please let me know if there is any workaround, apart from uninstalling and installing it again.

0 Likes
Highlighted
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Thank you Ana for the wonderful solution.

This solution has worked for me.

Regards,

Shiva Kumar Kothakota...

0 Likes
Highlighted
Cadet 3rd Class
Cadet 3rd Class

I faced the similar scenario and this worked for me 

Click on View -> Reset Window Layout and reset it...  Let me know if you face this issue again .. no need to uninstall it .. 

0 Likes
Highlighted
Commander
Commander

Hi Amit,

I can able to help you in this regards,please reach me if possible, so that
we will resolve the issue as early as possible.

Thanks
Balaji
91-9908286999

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.