New Ranks & Badges For The Community!
Notice something different? The ranks and associated badges have gone "Star Fleet". See what they all mean HERE
Highlighted
Absent Member.
Absent Member.
1937 views

QTP Take too long to execute the commands

QTP takes too long to execute the commands on few pages of my application, these pages has only text boxes and drop downs, My application is in .Net

I have recorded the test. now when i am trying to replay it, its taking time each step takes more than 3 min.

Please help me i am stuck because of this.. 😞
0 Likes
7 Replies
Highlighted
Absent Member.
Absent Member.

Sounds like a problem with Smart Identification. If you do not describe the object in OR well enough then Smart Ident kicks in and will make it longer to run your script also if you use the exist command.
0 Likes
Highlighted
Absent Member.
Absent Member.

Thanks Henry for your prompt reply, i tried it by disabling Smart Identification than also no success, still QTP is taking too much time to execute the commands.

URL: http://demo.bridgetrack.com/

Steps:
1) Type "test.forum" in UserName text box.
2) Type "pasword1" in password text box.
3) Click "Enter" button.
4) Paste the URL "http://demo.bridgetrack.com/email/email_configuration.asp?campaignid=517" in the address bar of the browser. Add Email Page will load in the browser.
5) Now record a script on Add Email Page.

Steps to record:
1) Type "abcefg" in Email Name text box.
2) Select "Marketing Email" in the Email Type combo box.
3) Type "wer123" in Subject Line text box.

Now try to run the recorded script, You will observe that QTP take long time to execute the commands.
0 Likes
Highlighted
Absent Member.
Absent Member.

Sorry Tried to log in but no luck.

0 Likes
Highlighted
Absent Member.
Absent Member.

Thanks Henry....For the effort you made to solve the problem..

How i can get the solution for this problem... 😞

Any pointers......As i need fix it ASAP...

Can any body solve my problem...
0 Likes
Highlighted
Absent Member.
Absent Member.

Ok where it is slow are you using Exist statements?

When you look at the results do you see any question marks next to the pages that are slow?

Are you using any recovery Scenario?

Also do you have fast selected on the Run option in QTP?
0 Likes
Highlighted
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Hi

If you used exist statements anywhere in yours script then u mention some time eg exist(1) so the execution or make sure that u have selected run mode as fast in tool-option-Runtab.




0 Likes
Highlighted
Absent Member.
Absent Member.

Yatish:
Is the Run mode of your application set to Slow(Tools, Options, Run)??
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.