Highlighted
Respected Contributor.
Respected Contributor.
1628 views

Scripting API is not... UFT in SAP

Hi everyone,

I am testing a case in SAP. Record almost everything fine and recognise elements in a good way. However sometimes I need to change the mode record to Windows. 

The problem is when I'm going to run the test sometimes works but other times appears this error:

"Scripting API is not enabled on this server. To record and run tests with QTP you must enable this option" 

I don't know how to solve that, I've read a lot of forums and explanations such as change the sap/user_scripting to TRUE and check tab scripting and uncheck the suboptions

Thanks in advance!

0 Likes
6 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Hi Tsachi,

Of course, I've tried that but the problem is still present!

I don't know what I must do!

Thanks for your help!

Sam

0 Likes
Highlighted
New Member..
New Member..

Hi,

I am also facing the same issue, can someone please help ,

i have checked the settings on tSAP server  rz11 (it is enabled) and SAP scripting options also enabled

Please reply ASAP.

Thanks,

Hari M

0 Likes
Highlighted
Valued Contributor.
Valued Contributor.

Hi Harl,

 

May I know which SAPGUI version you are using, 750 or 740? And is there any other application like NWBC Client is opened at the same time?

And when does the message "Scripting API is not enabled on this server. To record and run tests with QTP you must enable this option" show up? Always during record/spy/replay on any transaction or just one specific transaction or some transaction randomly? 

Any snapshot or video would also help to explain the case, we would appreciate that if it is okay for you to provide.

Thanks,

Mandy

0 Likes
Highlighted
New Member..
New Member..

HI Mandy,

Thanks for the reply.

I am using SAP GUI 740.

I am getting the same message whenever I try spy the objects for all transactions.

while recording UFT records as windows gui elements.

Please fidn the attached and suggest.

Thanks,

Hari

 

 

0 Likes
Highlighted
Valued Contributor.
Valued Contributor.

Hi Hari,

 

So you are using SAPGUI only and no other application like NWBC Client is launched in the same time?

May I know which UFT version you are using?

And could you please also attach a snapshot of parameter sapgui/user_scripting settings in the rz11?

 

Thanks,

Mandy 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.