Highlighted
Absent Member.
Absent Member.
503 views

Sometimes while running script i get error saying Cannot identify the object

Hello,

Sometimes while running script i get error saying -

Cannot identify the object "..." (of class ...) Verify that this object's properties match an object currently displayed in your application.

Tip: If the objects in your application have changed, the Maintenance Run Mode can help you identify and update your steps and/or the objects in your repository.

 

and  i rerun then script works fine!

Can someone explain me what might be the problem? Im a little bit confused why sometimes i get these errors and sometimes don't.

 

0 Likes
5 Replies
Highlighted
Honored Contributor.
Honored Contributor.

Re: Sometimes while running script i get error saying Cannot identify the object

Hi,

Which product suite are you working with?

 

HPE Community Manager
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Sometimes while running script i get error saying Cannot identify the object

I am working with UFT 11.50!

0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Sometimes while running script i get error saying Cannot identify the object

When it fails is the object UFT is referring to actually rendered?

It might be a synchronisation issue, what happens if you click Retry?

Mark Smith.

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Sometimes while running script i get error saying Cannot identify the object

when i click on retry still it throws the same error but if i stop and rerun  from begining then it will work!

Actually i encounter this error when i use a vbs script to launch the QTP and run the scripts, if i open UFT directly(i mean double clicking on exe and opening UFT) and run the scripts then scripts works fine!

i gave explicitewait and tried but still same issue! 

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Sometimes while running script i get error saying Cannot identify the object

And also when i launch UFT using a vbscript(Script is mentioned below)  and If I add a break point in my script and run it, execution is not stopping at the break point. Also, I see that "Step Over", "Step Out" and "Stop" icons are disabled.

And if i run normally then breakpoint will be enabled!

Could you please let me know how to fix this issue also?

 

Dim qtApp
Dim qtTest
Set qtApp = CreateObject("QuickTest.Application")
qtApp.Launch
qtApp.Visible = True
qtApp.Open "C:\test\QTP\Automated Regression Scripts\Regression_MasterScript", True
Set qtTest = qtApp.Test
qtTest.Run
qtTest.Close
qtApp.Quit

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.