Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Respected Contributor.. CarlHudson Respected Contributor..
Respected Contributor..
1064 views

Test Batch Runner no longer working after upgrade from UFT v11.5 to UFT v12

I have recently upgraded from UFT v11.5 to v12 and now find that when I run UFT Batch Runner, all my tests fail to run and give the message that 'QTP is not launched'

 

Have I missed something during the upgrade that has caused this...

 

I am running the same batch of tests that I have always run from the same batch file, location etc.. carrying out the same steps as I always have done. (Open Batch Runner > open the batch file> select all tests> enable the UFT button to use the UFT licence> press play). UFT is open in the background, as it always has been everytime I have run this in the past in v11.5.

 

Now UFT closes down in the background?

 

Both UFT and UFTBatchRunner are being run from shortcuts on the desktop  and being 'Run as administrator' as they always have been.

 

Has any one else experienced this, or can point out something that I should have done/enabled/disabled during the upgrade process?

 

FYI - the output details of the failed test gives the following details:

 

Creating an instance of the COM component with CLSID {2B9B8E92-EBAA-44AF-A23C-9FBD08EAFA54} from the IClassFactory failed due to the following error: 80004005 Unspecified error (Exception from HRESULT: 0x80004005 (E_FAIL)).
QTP is not launched.

 

Thanks.

Tags (1)
0 Likes
1 Reply
Tollens Absent Member.
Absent Member.

Re: Test Batch Runner no longer working after upgrade from UFT v11.5 to UFT v12

I get the same error after upgrading to v12

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.