Highlighted
Contributor.
Contributor.
345 views

[UFT 12.54 Patch 5] List selection changing itself

Hi,

Recently I updated UFT 12.54 with patch 5 (UFT_00194.exe), and now I have a problem with one WebList. I select one of the elements and after clicking a WeButton, the list selection reverts to initial state. e.g.

 .WebList("html id:=myList").select "4"

Then I do:

.WebButton("html id:=myButton").Click

The selection reverts to initial state (selected item index= 5).

Please help

0 Likes
2 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: [UFT 12.54 Patch 5] List selection changing itself

Hello there,

Hope you are doing great!

What happen if you replace the .Click action for an .Object.Click action and let us know the results.

To give you more useful option try to recollect the information requested below:

  1. Which kind of application are you using Web or Desktop? If this application is web, which browser and version do you have installed?
  2. Was working fine without the patch 5?
  3. Are you able to do the highlight action and having the same issue after the highlight action?
  4. This issue happens only in this specific part of the application only?

Finally, we can suggest you use descriptive programming on this script and have more details about this specific object, if you think this can be a good option, go ahead and check the information below:

 

Hope this information was useful for you.

If you find this or any other post resolves your issue, please be sure to mark it as an accepted solution.

If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the pond show your appreciation.

Best regards,

0 Likes
Highlighted
Contributor.
Contributor.

Re: [UFT 12.54 Patch 5] List selection changing itself

Hi,

The .Object.Click  action didn't help.

We test web apps and always use descriptive programming. The problem occured only for one of many WebList's.

I didnt't manage to do anything. Even if the list element was selected, it wasn't passed further - on next screen the value was totally different. After reinstallig UFT 12.54 without any patches, everything works fine.

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.