Highlighted
Regular Contributor.. Regular Contributor..
Regular Contributor..
1186 views

UFT Testing - jenkins - fails - cannot find Object's parent (class Browser)

Hi all,

I am struggling on running UFT tests via jenkins and UFT batch runner. While running tests via "Play" button of IDE everything runs successfully, but when it comes to run a build via Jenkins or via batch running it always fails.

I did a lot of investigation and tentative fixings but the issue is always about unable to find a Object I defined through Object Repository / VB script. Here's the attachments:Screen Shot 2018-10-22 at 14.13.24.pngScreen Shot 2018-10-22 at 14.12.58.pngScreen Shot 2018-10-22 at 12.50.54.pngAnyone can help me to understand why is keeping to fail please?

 

Thanks

Labels (3)
0 Likes
13 Replies
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: UFT Testing - jenkins - fails - cannot find Object's parent (class Browser)

Hello,

 

Can you please send the UFT and Jenkis version?

Its ALM involved?

Please check the next infoemation: https://admhelp.microfocus.com/uft/en/14.50/UFT_Help/Content/User_Guide/Jenkins.htm#mt-item-3

Thanks & Regards,

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: UFT Testing - jenkins - fails - cannot find Object's parent (class Browser)

Is it possible that UFT is restarted in between the builds and the target browser is started before UFT?

0 Likes
Highlighted
Regular Contributor.. Regular Contributor..
Regular Contributor..

Re: UFT Testing - jenkins - fails - cannot find Object's parent (class Browser)

Hello,

UFT version is 14.50, Jenkins is 2.138.

About ALM, no it's not involved.

Any ideas of how to fix the issue?

Thanks,

Andrea

0 Likes
Highlighted
Regular Contributor.. Regular Contributor..
Regular Contributor..

Re: UFT Testing - jenkins - fails - cannot find Object's parent (class Browser)

Hello,

mmm I don't know how to investigate this:(  how can I do this check?

 

Thanks,

Andrea

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: UFT Testing - jenkins - fails - cannot find Object's parent (class Browser)

hi,there

When you run from Jenkins server, please confirm the way of connection, documented in the plugin page. The jenkins process should be running in a session same as the remote desktop connection you have to maintain in order to run a Test successfully. 

As, you remote connect to the slave, connect to Jenkins server, DON'T close the remote desktop session, and start from Jenkins. 

Thanks.

James

0 Likes
Highlighted
Regular Contributor.. Regular Contributor..
Regular Contributor..

Re: UFT Testing - jenkins - fails - cannot find Object's parent (class Browser)


@JamesXue wrote:

hi,there

When you run from Jenkins server, please confirm the way of connection, documented in the plugin page. The jenkins process should be running in a session same as the remote desktop connection you have to maintain in order to run a Test successfully. 

As, you remote connect to the slave, connect to Jenkins server, DON'T close the remote desktop session, and start from Jenkins. 

Thanks.

James


Hi James,

thank you for your reply and suggestion, I will try to follow your instructions.

Let you know, thank you, kind regards,

Andrea

0 Likes
Highlighted
Regular Contributor.. Regular Contributor..
Regular Contributor..

Re: UFT Testing - jenkins - fails - cannot find Object's parent (class Browser)

Hi,

we tried but nothing new. But it also fails locally on IDE now, without touching anything.

Attaching screenshots of test report 

Screen Shot 2018-10-26 at 12.40.25.pngScreen Shot 2018-10-26 at 12.40.42.pngScreen Shot 2018-10-26 at 12.16.44.png

 

Any ideas please? I am trying everything without any success

Note: seems browser app page does not exist. why?

Screen Shot 2018-10-26 at 12.54.57.png

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: UFT Testing - jenkins - fails - cannot find Object's parent (class Browser)

hi, there

If the problem exists on local IDE, it's a different matter then. Can you check if the browser is launched properly? and the properties match those in the object repository?  At the step where the script cannot continue, what is the status of the application you're testing?

Thanks.

James

0 Likes
Highlighted
Regular Contributor.. Regular Contributor..
Regular Contributor..

Re: UFT Testing - jenkins - fails - cannot find Object's parent (class Browser)


@JamesXue wrote:

hi, there

If the problem exists on local IDE, it's a different matter then. Can you check if the browser is launched properly? and the properties match those in the object repository?  At the step where the script cannot continue, what is the status of the application you're testing?

Thanks.

James


Hi James, 

yes, don't know what is happened but now also in my local IDE it fails. Odd thing is that everything seems ok in the flow of execution: first test action is completed, then it goes on the same failing action and it breaks. Please find the status of the application in the following screenshots.

Thanks

 

1. it breaks here: displayed error1. it breaks here: displayed error2 last method run (*): param 12 last method run (*): param 13 (*): param 23 (*): param 24 (*): browser instance4 (*): browser instance5 (*): Object not found error5 (*): Object not found error6: Search Client exist in repo!6: Search Client exist in repo!7 Test flow: all good until selectClient when it fails7 Test flow: all good until selectClient when it fails

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: UFT Testing - jenkins - fails - cannot find Object's parent (class Browser)

hi, zux

I am sorry for the inconvenience. However, with the snapshot, I failed to comprehend the real issue. If you can send the script for me to run, it will be great. The object, in the OR, is somehow not reachable from the Action, is that right? 

If the problem is beyond the availability to assist on forum, you're always welcome to open a support ticket to Microfocus Support.

Thanks.

James

0 Likes
Regular Contributor.. Regular Contributor..
Regular Contributor..

Re: UFT Testing - jenkins - fails - cannot find Object's parent (class Browser)

 


@JamesXue wrote:

hi, zux

I am sorry for the inconvenience. However, with the snapshot, I failed to comprehend the real issue. If you can send the script for me to run, it will be great. The object, in the OR, is somehow not reachable from the Action, is that right? 

If the problem is beyond the availability to assist on forum, you're always welcome to open a support ticket to Microfocus Support.

Thanks.

James



Sorry James, for privacy/copyright reasons I can't send you the ftsln solution project.

If you can send me the link to microfocus support il would be great, thanks

 

Andrea

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.