Highlighted
Absent Member.. Absent Member..
Absent Member..
112 views

UFT not working - getting message "spcified cast is invalid"

In February of this year, I recorded a test, and saved it locally to my desktop. The next day when I opened UFT, I got a message “specified cast is invalid” when it tried to auto-login to Quality Center (ALM), and I could not open any existing test on my machine, or manually log in to ALM to open any of the tests stored there.

Working with HP support, after a clean uninstall/reinstall, it worked again, but only for one test. After recording and saving one test to desktop, the next time I opened UFT I got “specified cast is invalid” message again, and it has been that way ever since.

I have been working with HP support for almost 3 months now without success. We have tried the following actions:

Clean uninstall/reinstall

Installed UFT 12.02

Unregister/register DLLs

Reinstall .net files

Installed UFT 11.53 on new machine

install HP ALM Connectivity Add-in for UFT

Replaced “HP.QTP.Backend.Common.dll”

Provided HP support with multiple log files

 

I have googled this error message and found other users are getting it but no solutions. Does anyone here know what the problem is?

0 Likes
2 Replies
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: UFT not working - getting message "spcified cast is invalid"

Hi Wilsonka

 

Hope you are doing well.

 

Searching about you issue i found that this is documented and also have a solution, please refer the below document or more information:

 

https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM00463358

 

"This issue can happen when improper script is used in workflow, but if it happens to major actions, it can be causd by corrupted registry entry at HKEY_CLASSES_ROOT\\CLSID\\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}\\InprocServer32.

 

After changing the value of (Default) key to point to the correct location of vbscript.dll, the issue should be resolved."

 

Hope this will help you.

 

Best regards.

Ruddy Alvarez H.
Customer Support Engineer

If you find thst aat this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the pond show your appreciation.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: UFT not working - getting message "spcified cast is invalid"

I checked this registry entry, and it already looks like the picture that you provided - the default item reads "C:\Windows\System32|vbscript.dll".

 

Thanks for answering, but this does not seem to be tha cause of my issue either.  HP support has been trying to fix this for over 3 months now.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.