Highlighted
Absent Member.
Absent Member.
782 views

UFT unable to recognize any object on our .NET application .Throws error.

We are trying to automate our .NET based application through UFT 11.53 (Unified Functional testing) tool. After installing the concurrent licenses and including all the required add-ins when we try to record and playback any scenario we see certain errors that do not allow us to playback any of the recorded scripts.

Here is a quick summary of present situation.

 

Current Status :

 

We tried using the record and playback method as well as Object spy method to automate our application using UFT . The tool doesn’t seem to recognize any object in the application and throws error related to chrome widget (“SwfWindow("frmMain").WinObject("Chrome_RenderWidgetHostHWND")”)  when we run the script generated. Our application uses Chromium engine to render its pages and the version used (Chromium 31) is incompatible with UFT 11.53 . In order to get the compatibility we installed UFT_00044+ and UFT_00068 patches with UFT but issue still remains the same.

 

The version specifications used are :

 

  • UFT version 11.53 BUILD 0501
  • UCA version 15.2.0.30
  • .NET version 4.0.30319
  • IE Version : 8.07601
  • Chromium Version 31

 

 

It would be great if you could advise on any further actions that we can take or assist with any suggestions to enable tool for the required functionality. In case you are aware of anyone else who could guide us on the same then please share the contact details so that we can reach out to them  .

 

0 Likes
2 Replies
Highlighted
Absent Member.
Absent Member.

Re: UFT unable to recognize any object on our .NET application .Throws error.

Hi Try below 1. Try Repairing the UFT from Control Panel if the above not solves your issue then, 1. Clean Uninstall UFT, Uninstall .NET framework 4.5/4 2. Install .NET framework 4.5 first then install UFT ///Kiran///
0 Likes
Highlighted
New Member.

Re: UFT unable to recognize any object on our .NET application .Throws error.

If you have enabled the Chrome UFT agent, try by disabling the agent in Extensions.

 

Also ensure you are folowing these.

http://shanmugavelc.blogspot.com/2015/05/qtp-object-identification-prerequesties.html

Accept as solution/Give Kudos to the author if the piece of information answered/helped you to solve your problem.
All the thoughts here are mine not related to my employer nor anyone.
Test Automation Ecstasy
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.