Highlighted
Regular Contributor.
Regular Contributor.
218 views

When running scripts in UFT - they take up to two hours and more.

Hello,

We are running scripts in UFT which take up to 2 hours and more (when executed manually it's much faster).

Can you please give us advice what could be possible causes of this problem.

 

Thanks

 

0 Likes
1 Reply
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: When running scripts in UFT - they take up to two hours and more.

You can try a couple of things.

Review your script for Wait statements & replace them with Sync statements.

Review your Object Repository & see if Smart Identification is enabled. If it's enabled, you might have to re-configure your objects without Smart Identification.
You can also open your test reports and look for an Icon with a hat. If you see this, then Smart Identification is invoked.
_____________________
Rajkumar Rajangam
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.