Highlighted
Visitor.
1232 views

unable to recognize SAP GUI objects

Hi Experts,

I'm trying to create an automation script for SAP GUI application however, It seems that UFT doesnt recognize the objects well, it identifies the SAP GUI as Windows (see attached file)

I have installed all the necessary SAP pulgins and enabled script on both server and client side of SAP (see attached file)

Am I missing something?

other information:

UFT ver 14

SAP ver 740

SAP kernel release 742

SAP package level 401

 

 

Tags (1)
0 Likes
2 Replies
Highlighted
Contributor.
Contributor.

Hello,

You need to make sure you open the application after launching UFT. Opening the AUT first sometimes caused UFT to not properly identify objects.

You can also check your Record and Run setting to work on any open applications.

Hope this helps.

Regards, Vince

0 Likes
Highlighted
Visitor.

Hi Vince,

Thanks for replying, I have done this steps but still doesnt work, I'm looking at a poosible environment issue since DEV/QA/Prod are all in the same server.. I'm thinking of installing SAP and UFT on the differnent machine, but I guess, it will take a lot of time.

Thanks,,

P

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.