Highlighted
rockstarta78
New Member.
353 views

Help Please

I am using UFT 12.52. I am trying to automate a report which is built on SAP HANA. When I record my script it records everything accurately. I used the object spy highlighter to validate that the objects are being highlighted accurately.  If I run the below code it fails with an error message (added at the bottom). But if I re-run the code without closing the previously opened browser window the code will pass. I am so lost. Please help

 

 

SystemUtil.Run "C:\Program Files\Internet Explorer\iexplorer.exe",""","%HOMEDRIVE%%HOMEPATH%",""

Browser("Launch Pad").Page("Launch Pad")..Sync
Browser("Launch Pad").Page("Launch Pad").Frame("Frame").WebElement("User Run Reports").click

Browser("Launch Pad").CloseAllTabs

 

This is the error I receive:

Cannot find the "User Run Reports" object's parent "Frame" (class Frame).

Verify that parent properties match an object currently displayed in your application. 

In my OR, I have made sure FRAME has Title, html tag, and html_id (since name is missing). when I use object spy to highlight the frame it highlights the entire page. Please help

0 Likes
1 Reply
Micro Focus Expert
Micro Focus Expert

Re: Help Please

Hi,

Just for debug purposes, did you try to add a wait statement before the click command? if the error thrown immediatly or is it waiting for the timeout?

Tsachi

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.