Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
rdgrindle Contributor.
Contributor.
96 views

Looping over an XML

I am trying to use an XML as a data source. I want to loop over the nodes that the XML provides. Loading the XML in UFT works fine, in the data view the XML is displayed as an array with multiple rows.

But when I use the XML in a Flow Control Loop, it only recongnizes the first row and thus only executes the test once.

Does any one have a solution?

Please do not post me code how to loop through an XML, I know how to do that. It's about using the UFT Loop functionality!XMLinUFT.png

0 Likes
2 Replies
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: Looping over an XML

Hello there.

 

Have you checked on this link from the help enter? https://admhelp.microfocus.com/uft/en/14.51/UFT_Help/Content/User_Guide/ref_add_query_to_loop.htm

 

I saw that you are figuring this out on an API test. I think you can take a look at the above for guidance.

 

regards, 

0 Likes
rdgrindle Contributor.
Contributor.

Re: Looping over an XML

Hello Jean,

thank's for the rtm. I did exactly what the guideline says.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.