RicoLee Absent Member.
Absent Member.
6592 views

QTP test script in read-only

Greetings, I have some QTP scripts running on schedule. today I found the existing QTP scripts I open are in Read-only mode, as it shows the script is being opened by a user, which is myself. There are no other users or applications that would invoke the QTP session or create connection to it. Even a system reboot is not able to release the locked test script.

Does anyone knows of a possible cause and solution for this? Thanks in advance.

.-asd-.
0 Likes
10 Replies
Ana_Noncheva Absent Member.
Absent Member.

Re: QTP test script in read-only

Hi,

 

You could see and also release the lock from ALM Site Administration, if needed.

Select and expand the project in which the locked test resides. Select the Locks table. You should see the locked test listed. If you need to release it, execute following SQL:

DELETE FROM LOCKS WHERE LK_CLIENT_MACHINE_NAME = 'MachineName'

 

Regards,

Ana

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
RicoLee Absent Member.
Absent Member.

Re: QTP test script in read-only

Not sure if I am getting this right, but we do not have ALM installed.

.-asd-.
0 Likes
Highlighted
Absent Member.. vzamoraz Absent Member..
Absent Member..

Re: QTP test script in read-only

What are you using to run the scripts on schedule?

Did you use Test batch runner in order to group the tests?

 

Note: The Opinions expressed in my post are mine alone, and do not reflect the opinions of my employer. No warranties express or implied for any answered posted.

Also remember if you have a valid contract with HP feel free to visit our FT/QTP Support Customer Forums: http://h30499.www3.hp.com/t5/Functional-Testing-QTP/ct-p/sws-Fun_Test
You can create an account with your HP credentials.

0 Likes
AnkurJain Frequent Contributor.
Frequent Contributor.

Re: QTP test script in read-only

What is the version of QTP? Where are your scripts stored? is it some shared location? 

There appears to be some conflict with the user profile on your machine.

 

As a starting point, go inside the script folder and try to locate lock.lck file and delete it.

 

Also see if this thread can help you.

 

Let us know how it goes.

------------------------------------------------------------
Please make sure to "Kudos" on the left and mark the thread as resolved if this has answered your query.
------------------------------------------------------------
0 Likes
RicoLee Absent Member.
Absent Member.

Re: QTP test script in read-only

I am using Windows Scheduler to run batchfiles that will initiate VB scripts to call the tests. It always been without any issues.

The tests files are located in local folder where all users can be accessed. I have tried removing lock.lck but it seems to be same. Even tests that I created long ago and were not being used since then are also in read-only mode.

I only noticed this issue recently, I think one of the culprit is LoadRunner's Virtual User Generator, as the test folder had been changed to its icon as well.
.-asd-.
0 Likes
csm2mk Absent Member.
Absent Member.

Re: QTP test script in read-only

I try to understand...

 

Maybe you have an open session elsewhere?

 

From your original question I did not get if you mean that the file is locked by you from some other session...

0 Likes
RicoLee Absent Member.
Absent Member.

Re: QTP test script in read-only

That is why I am wondering too, there is no other open session, the script is still in read-only mode even after i rebooted the machine.
.-asd-.
0 Likes
Ana_Noncheva Absent Member.
Absent Member.

Re: QTP test script in read-only

Hi RicoLee,

 

Are all tests in this folder read-only? Can you check permissions for this folder?

 

As from QTP side, try the following:

1. Disable the UAC (User Account Control) and the Symantec Antivirus, if you have.

2. Then go to the registry -> Start -> Run -> Type “regedit” (without quotes).

3. Backup and delete the following folder: HKEY_CURRENT_USER\Software\Mercury Interactive\QuickTest Professional

4. Go to Start -> Run -> Type “%APPDATA%” (without quotes).

5. Go to the HP folder and delete the QuickTest Professional folder.

6. Perform a “Repair” installation of QTP from Control Panel

7. Launch QTP again.

 

Regards,

Ana

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
RicoLee Absent Member.
Absent Member.

Re: QTP test script in read-only

All the tests in that machine are read-only, I have checked the permission and it has no changes that would prevent me from perform anything in the folder.

I've tried the registry edit and repair suggestion as well, but it is still in read-only mode when I open up the tests.
.-asd-.
0 Likes
MumQA Absent Member.
Absent Member.

Re: QTP test script in read-only

HI,

Please delete all the .lck files in your project folder and then try.

it worked to me. Good luck.

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.