Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
Super Contributor.. mu21 Super Contributor..
Super Contributor..
834 views

UFT 14.03 Suddenly Stops Recognizing Web Objects

Hello,

I'm using UFT 14.03, patch 3 with Chrome 70.0.3538.110. Everything was working fine but yesterday, UFT suddenly stopped recognizing Web objects. Even though the web add-in is loaded, all objects are identified as Win objects and I cannot run my tests anymore.

I tried repairing UFT, it didn't help. I uninstalled and reinstalled UFT and all patches and again, nothing changed. I also uninstalled and reinstalled Chrome, verified that the UFT extension is activated, I also uninstalled and reinstalled the UFT extension .... but nothing helps.

Apparently, the problem occurs only with Chrome, not with IE. Has anybody encountered this problem before? Any idea on what might resolve this problem?

Thanks

16 Replies
Knowledge Partner
Knowledge Partner

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

Only time I saw this was when I mistakenly installed Chrome with "automatically update" set to true. A few months later a new (unsupported) version of Chrome auto-installed and killed my tests.

Sounds like you have rolled back to the last working version so this can't be your issue. Sorry I couldn't be of more help.

Mark Smith.

Super Contributor.. mu21 Super Contributor..
Super Contributor..

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

Hello,

Thanks for your reply.

Chrome is set not to update automatically. I do it manually after testing that everything is OK. I checked, just to make sure, and no Chrome updates since December 8. No update on the machine either, nothing has changed since last night.

It really beats me. I have no clue what's going on

 

Respected Contributor.. Bolagsverket Respected Contributor..
Respected Contributor..

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

Having the exact same problem, seems to work with version 14.50 of UFT but that breaks other parts of our test suite using the java addin.

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

We have this issue as well. It also doesnt work on UFT 14.50 for us.

It worked up until yesterday / this morning. Chrome has not been updated.

Tested on Chrome 68 and 71. Tested with UFT 14.03 and 14.50. Tested on Windows 7 and Windows 10.

jmahaffey Trusted Contributor.
Trusted Contributor.

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

I am having this same issue as well.  I am on a newer version of Chrome, but like you it was working throughout the day and then it just stopped working.

0 Likes
Highlighted
Super Contributor.. mu21 Super Contributor..
Super Contributor..

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

Hello,

Thank you everyone for your response. I was glad to see I wasn't the only one with this problem.

I opened an incident and MicroFocus informed me they are aware of the problem and currently working on a solution.

 

Frequent Visitor.. kristin wakefield
Frequent Visitor..

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

We are impacted too. I opened an incident with MicroFocus and am waiting a response. my team noticed the issue today after upgrading to chrome 71, we tried to upgrade UFT 14.03 to 14.5 and we still have the issue of recognizing web objects as win objects. 

0 Likes
Trusted Contributor.. mherbert_1 Trusted Contributor..
Trusted Contributor..

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

Same here. We are dead in the water at this point. If you learn of anything, whether it be from the Community feedback or Micro Focus Software Support, please do share ASAP.  I need to get back up and running on Chrome. 

Mark Herbert
Software Quality Manager / Engineer
Micro Focus Accredited Solutions Expert (ASE)
Micro Focus Certified Instructor (CI)
0 Likes
newbieny Regular Contributor.
Regular Contributor.

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

will you please let us know if you get any answwer from them.

we were supposed to buy it next week 

everything was working than rigt at the time of demo it just destroyed.

looking forward to hear back from you 

thanks

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

I quote @Phenomite from https://community.softwaregrp.com/t5/Unified-Functional-Testing-User/UFT-14-03-Build-3501-not-recognizing-Google-Chrome-71-0-3578-98/td-p/1681220

"This is caused by a silent patch that has rolled out to address fullscreen and popup sandboxing issues with extensions using gesture APIs. A chromium forum engineer posted the changed code which directed me in how to fix it.

-> Open chrome://flags.

-> Search for "Touch events API" and set it to "Enabled"

-> Search for "User Activation V2" and set it to "Enabled"

-> Click the restart chrome prompt.

 

If you are interested, the patch code that fixed (but broke) extension gestures API: https://chromium.googlesource.com/chromium/src/+/6b20212bdffccd581703de1f229921151ea4750b/extensions/renderer/bindings/api_request_handler.cc#264"

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

hi, there

Out of a sudden, the problem appears for no apparent reason. Either UFT nor Chrome updates anything from what we can see. There are many face the same problem and R&D is doing our best to give a solution and update the fix.

At the initial stage, we found there's a field UFT is using has been changed. 

Thanks.

James

0 Likes
Super Contributor.. mu21 Super Contributor..
Super Contributor..

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

Hello,

I saw this post but I'm not too keen on changing some configurations without knowing what the impact of these changes may be.

I'm still waiting for some official news from MicroFocus. This morning I found out that it is working again on the machines where I either uninstall/reinstalled Chrome 70 or updated it to Chrome 71, which is available starting today in our company. But like I said, I'm still waiting for some news from MicroFocus.

0 Likes
Respected Contributor.. Bolagsverket Respected Contributor..
Respected Contributor..

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

Google seems to have fixed the issue with a new patch. Have tried it with UFT 14.03 and it now works again for me.

0 Likes
jmahaffey Trusted Contributor.
Trusted Contributor.

Re: UFT 14.03 Suddenly Stops Recognizing Web Objects

I enabled both of these flags and it still does not work.

Edit: It seems to be working now.  WIll update if anything changes

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.