vincent90152900 Absent Member.
Absent Member.
23396 views

You do not have permissions to run tests on this machine. You can change this option in your testing

Jump to solution

Hi, I run a QTP test on QC, and i get the error message ,"You do not have permissions to run tests on this machine. You can change this option in your testing tool's Options dialog box.".

How do I solve this?

 

 

P.S. This thread has been moved from Quality Center Support and News Forum to Unified Functional Testing (formerly QTP) News and Support Forum. - Hp Forum Moderator

0 Likes
1 Solution

Accepted Solutions
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: You do not have permissions to run tests on this machine. You can change this option in your testing

Jump to solution
In the Options dialog in QTP, check the box Allow other HP products to run...
Jan Czajkowski

[Please do not contact me off line for receiving support. Use the forum!]
15 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: You do not have permissions to run tests on this machine. You can change this option in your testing

Jump to solution
In the Options dialog in QTP, check the box Allow other HP products to run...
Jan Czajkowski

[Please do not contact me off line for receiving support. Use the forum!]
vincent90152900 Absent Member.
Absent Member.

Re: You do not have permissions to run tests on this machine. You can change this option in your testing

Jump to solution
Many thanks for your replying.

Thank you very much.
0 Likes
shreshtha Absent Member.
Absent Member.

Re: You do not have permissions to run tests on this machine. You can change this option in your testing

Jump to solution
Many Thanks for solution 🙂
0 Likes
csutter2002 Absent Member.
Absent Member.

Re: You do not have permissions to run tests on this machine. You can change this option in your tes

Jump to solution
Thanks! I spent many hours trying to figure out this problem in ALM! (QC)
0 Likes
qc Solution Man Absent Member.
Absent Member.

Re: You do not have permissions to run tests on this machine. You can change this option in your tes

Jump to solution

I'm using QTP 11. I could not locate this option "Allow other HP products.." where exactly it is.

 

I checked under Tools | Options..

 

please let me know.

 

thanks

 

0 Likes
Absent Member.. RajuThomas Absent Member..
Absent Member..

Re: You do not have permissions to run tests on this machine. You can change this option in your tes

Jump to solution
1.From QTP Main Menu Tools > Options > Run
2.Place check in the box labeled 'Allow other HP products to run tests and components'.
3.Press 'Ok' button
4.Close QTP
0 Likes
Absent Member.. d1morto Absent Member..
Absent Member..

Re: You do not have permissions to run tests on this machine. You can change this option in your tes

Jump to solution

Did something change on this in UFT? I am running UFT v12.00 build 0511. Under Tools->Options->General->Run Sessions, I don't see anything like the above. The only thing close I see is:

 

"Allow UFT to continue running GUI or business process tests after disconnecting from and RDP computer."

 

That doesn't sound really sound like the same thing, though. My error message is exactly the same, though:

 

"You do not have permissions to run tests on this machine. You can change this option in your testing tool's Options dialog box."

 

 

0 Likes
Damodar-Reddy Acclaimed Contributor.
Acclaimed Contributor.

Re: You do not have permissions to run tests on this machine. You can change this option in your tes

Jump to solution

You can find the relevant,

 

Have a look on user guide for the same.

 

Note: If this feature is default in UFT 12.01 I am not really sure(Anyhow this must be an optional for this tool)

(If this helped, accept as solution )
(Posts and opinions made here are my own and do not reflect the opinions of my employer)
Highlighted
Absent Member.. Trudy Claspill Absent Member..
Absent Member..

Re: You do not have permissions to run tests on this machine. You can change this option in your tes

Jump to solution
In UFT 12 the option is under Tools > Options > GUI Testing > Test Runs
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
Damodar-Reddy Acclaimed Contributor.
Acclaimed Contributor.

Re: You do not have permissions to run tests on this machine. You can change this option in your tes

Jump to solution
Good One Trudy,

I haven't viewed UFT 12 yet...!!
(If this helped, accept as solution )
(Posts and opinions made here are my own and do not reflect the opinions of my employer)
Absent Member.. d1morto Absent Member..
Absent Member..

Re: You do not have permissions to run tests on this machine. You can change this option in your tes

Jump to solution

Ah, there it is! Thanks, you have made me very happy!

0 Likes
Sreekar_SNPS Absent Member.
Absent Member.

Re: You do not have permissions to run tests on this machine. You can change this option in your tes

Jump to solution

The 'Run' option is disabled on WEB QC 11.  Please suggest to set it as enabled.

0 Likes
Absent Member.. srekkk Absent Member..
Absent Member..

You do not have permissions to run tests on this machine. You can change this option in your test

Jump to solution

I have another issue with respective running UFT scripts in ALM.

 

The error I am getting when I run the script is:

 

"You cannot run the test as you do not have sufficient permission to create or update the performance testing timeslot. For more information, contact administrator"

 

Can anybody help me to fix it?

 

The script is about automating web application, here is the glance of script:

 

'Navigating through Amazon pages

Dim ie1'as IEBrowserobject

'Associate Object Repository
Dim obr
RepositoriesCollection.RemoveAll()
RepositoriesCollection.Add "[ALM\Resources] Resources\Object Repository for UFT\Repository_Amazon pages.tsr"

 

' [ALM\Resources] Resources\Data Table for UFT\AmazonsiteDatatable
'Create browserobject and open the url: www.amazon.com
Set ie1 = CreateObject("InternetExplorer.Application")

ie1.Visible = True
ie1.Navigate "www.amazon.com"

0 Likes
Gary-ODJFS
New Member.

Re: You do not have permissions to run tests on this machine. You can change this option in your tes

Jump to solution

I did Tools-->Options-->Restore Factory Defaults then reconnected to ALM and it fixed the problem.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.