Absent Member.
Absent Member.
2419 views

HPUcmdb 9 Query result exceeded size limit

Jump to solution

 

 

Hi on trying to get the result from my TQL I get this error. How to change this setting.
 
This is on HP uCMDB 9
 
 
Query result exceeded size limit.
Please refine your query.
Cause : query objects by condition.
Size limit: 2000000
 
Any solutions.  where to modify this setting
 
 
P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to CMS and Discovery Support and News Forum. - Hp Forum Moderator
0 Likes
1 Solution

Accepted Solutions
Absent Member.
Absent Member.

Hi Rutger,

 

  Thanks for the response. It helped me out to resolve the issue other way.

I could not locate/modify the seting through JMX Console, but I could override the entry you specified 'dal.object.condition.max.result.size' in the settings.overide file and it worked for me.

 

Go to "<uCMDBinstallLocation>\UCMDBServer\conf" 

Edit file "settings.override". In this file append text as below (or if dal.object.condition.max.result.size already there, increase its size as required):
dal.object.condition.max.result.size=SomeX


number

Now, Save the file and restart the HP uCMDB server.

View solution in original post

0 Likes
3 Replies
Vice Admiral
Vice Admiral

Try the JMX console, under Settings Services, look for "dal.object.condition.max.result.size".

I did NOT try this (so beware), would be nice if you could let me know how it turns out.

It would be a really good idea to try this in your LAB or TEST environment, otherwise caveat emptor! 🙂

Not that I see any serious problems on the horizon, as it's a setting that on the face of it would affect memory and temp disk space consumption. Could lead to a hanging system however, which can be annoying.

 

Absent Member.
Absent Member.

Hi Rutger,

 

  Thanks for the response. It helped me out to resolve the issue other way.

I could not locate/modify the seting through JMX Console, but I could override the entry you specified 'dal.object.condition.max.result.size' in the settings.overide file and it worked for me.

 

Go to "<uCMDBinstallLocation>\UCMDBServer\conf" 

Edit file "settings.override". In this file append text as below (or if dal.object.condition.max.result.size already there, increase its size as required):
dal.object.condition.max.result.size=SomeX


number

Now, Save the file and restart the HP uCMDB server.

View solution in original post

0 Likes
Vice Admiral
Vice Admiral

Excellent. Thanks for the additional explanations!

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.