Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
Highlighted
Jeff0489
Member.
894 views

failed backup

Hi,
When execution scheduled backup, sometimes success sometimes fails
failure message as follows

-------------------------------
Failed: The target directory

"[NFS-VMBK] VMX-VC6/AP1/2018-01-09"
could not be created (ESX webservice failed to create the directory
'[NFS-VMBK] VMX-VC6/AP1/2018-01-09,

retried 3 times (Invalid datastore path '/vmfs/volumes/2646eeb3-d012ebfb/VMX-VC6'.))
------------------------------

backup to NFS datastore on QNAP nas
HPE VM Explorer® 6.5.001 (64-bit)

Is there any known workaround about this problem?

Labels (1)
0 Likes
2 Replies
Ashok Goyat Respected Contributor.
Respected Contributor.

Re: failed backup

Hello,

It seems you are using ESXi webservice instead of VMX agent for file transfer. If that is the case then, I recommend to use the VMX Agent option (if ESXi version is 4.1 or higher): you can have a better performance and a more stable connection on your ESXi hosts.

When the agent option is enabled file transfers are performed by the agent thus avoiding the use of ESXi webservice and increasing the overall performance and the reliability of the backup. The VMX Agent is a little executable responsible for the file transfers.  To check and activate this option, follow these steps:

Start VM Explorer

Switch to the "Datacenter" tab

Right-click your ESXi server in the "My Datacenter" list and choose "Edit Server..."

Press "next" untill you reach on option "SSH/HPE VM Explorer Agent".

Select option "Enable SSH and use HPE VM Explorer Agent automatically (only on ESXi 4.1 or higher) 

 also "Enable the "use SSH (SCP) to transfer files if this is an ESXi 4i/5i/6i host"

The option will also enable "Try to use the HPE VMX agent on ESXi ....." For this option TCP ports 62000-65000 needs to open. Refer VM Explorer user guide for more details. 

Test your connection

if all is okay save the changes.

=================== 

To ensure VM Explorer uses the new connections, close VM Explorer and start it again. Now, it should automatically use the Agent. 

Hope this helps.

Regards

Ashok Goyat

0 Likes
Jeff0489
Member.

Re: failed backup

thanks for your advice
already follow the steps setup
keep observing.......

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.