Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Highlighted
Anonymous_User Absent Member.
Absent Member.
1089 views

New 4.0.5 install on SLES 15 no web response

Hi,

new server, new problem

My first SLES 15 server was installed by coworker.
Small installation w/o packages (just ssh, I had to add vnc manually).

- mariadb-10.3.13-linux-systemd-x86_64.tar.gz installed by hand
- added tk-32bit and tcl-32bit using yast
- vibe user and group created
now I could start the vibe installation procedure
installer.log reports all ok
- database created
- database properties assigned

Some show stopper: documentation recommends sles 15 or oes 18, but
firewall configuration steps points to old sles 11 or sles 12.

I disabled firewall completely ATM, because I have the command line
configuration only.

So I started the vibe service. Top reports the heavy cpu load by java.
ps -eaf | grep teaming shows a running process.

ss -4 -n -l reports no open ports on 80, 443, 8080 or 8443

catalina.out contains no errors, eventually this warning:
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.dom4j.io.SAXContentHandler
(file:/opt/novell/teaming/apache-tomcat/lib/ext/dom4j.jar) to method
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser$LocatorProxy.getEncoding()

also appserver.log with warnings only

what can I do?

Gotthard





--
Gotthard Anger
Anwenderbetreuung Netzwerkadministration
Landeskirchenamt der EKM
gotthardanger@no-mx.forums.novell.com
https://forums.novell.com/member.php/35038-gotthardanger

Mails an diese Adresse werden nur nach vorheriger Ansage gelesen!
Mails for this address will only be read if you trigger me before.
0 Likes
4 Replies
Micro Focus Expert
Micro Focus Expert

Re: New 4.0.5 install on SLES 15 no web response

Hi Gotthard,

As per the documentation, were the additional modules installed for SLES 15?

https://www.novell.com/documentation/vibe4/vibe4_inst/data/b1dgvtdh.html

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: New 4.0.5 install on SLES 15 no web response

Am 18.03.2019 um 12:14 schrieb laurabuckley:
>
> Hi Gotthard,
>
> As per the documentation, were the additional modules installed for SLES
> 15?
>
> https://www.novell.com/documentation/vibe4/vibe4_inst/data/b1dgvtdh.html


As I wrote:
tk-32bit and tcl32-bit were installed. Without these modules the install
process will not start.

My question points to apache.

Gotthard


--
Gotthard Anger
Anwenderbetreuung Netzwerkadministration
Landeskirchenamt der EKM
gotthardanger@no-mx.forums.novell.com
http://forums.novell.com/member.php?u=35038
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: New 4.0.5 install on SLES 15 no web response

Hi,

finally solved in no safe way 😞

provided way by docs with file /etc/init.d/after.local did not work.

So I had to do the hard path:

setting all ports in installation procedure to 80/80 and 443/443 and got
a warning, the vibe service has to run as root.
So I cancelled the installation, start new with root as service owner
and now vibe is working.

The migration from the old sles11 is also done.

In any matter I have broken the MariaDb configuration. Service was dead
after system start and I had to reanimate with systemctl restart mysql.

So I followed
https://superuser.com/questions/384365/systemctl-enable-differs-from-systemctl-start-how

and wrote my own mysql.service. Additionally I moved mysql from
/etc/init.d to an other position for using with mysql.service

now all running fine.

HTH
Gotthard





Am 18.03.2019 um 09:47 schrieb Gotthard Anger:
> Hi,
>
> new server, new problem
>
> My first SLES 15 server was installed by coworker.
> Small installation w/o packages (just ssh, I had to add vnc manually).
>
> - mariadb-10.3.13-linux-systemd-x86_64.tar.gz installed by hand
> - added tk-32bit and tcl-32bit using yast
> - vibe user and group created
> now I could start the vibe installation procedure
> installer.log reports all ok
> - database created
> - database properties assigned
>
> Some show stopper: documentation recommends sles 15 or oes 18, but
> firewall configuration steps points to old sles 11 or sles 12.
>
> I disabled firewall completely ATM, because I have the command line
> configuration only.
>
> So I started the vibe service. Top reports the heavy cpu load by java.
> ps -eaf | grep teaming shows a running process.
>
> ss -4 -n -l reports no open ports on 80, 443, 8080 or 8443
>
> catalina.out contains no errors, eventually this warning:
> WARNING: An illegal reflective access operation has occurred
> WARNING: Illegal reflective access by org.dom4j.io.SAXContentHandler
> (file:/opt/novell/teaming/apache-tomcat/lib/ext/dom4j.jar) to method
> com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser$LocatorProxy.getEncoding()
>
>
> also appserver.log with warnings only
>
> what can I do?
>
> Gotthard
>
>
>
>
>



--
Gotthard Anger
Anwenderbetreuung Netzwerkadministration
Landeskirchenamt der EKM
gotthardanger@no-mx.forums.novell.com
https://forums.novell.com/member.php/35038-gotthardanger

Mails an diese Adresse werden nur nach vorheriger Ansage gelesen!
Mails for this address will only be read if you trigger me before.
0 Likes
DonW
New Member.

Re: New 4.0.5 install on SLES 15 no web response

Hi Gotthard,

Running Vibe with root is not recommended as there is security risk.
It is better sticking with port 8080 and 8443 and run Vibe with a normal
user. You can set up port forward if you don't want users typing port
numbers.

Yes, the Vibe documentation on firewall is outdated. You need to take
it as a reference and set it up with firewalld (firewall-cmd). Alternatively,
you can use iptables script directly.

Cheers

Donald

Gotthard Anger;2498544 wrote:
Hi,

finally solved in no safe way 😞

provided way by docs with file /etc/init.d/after.local did not work.

So I had to do the hard path:

setting all ports in installation procedure to 80/80 and 443/443 and got
a warning, the vibe service has to run as root.
So I cancelled the installation, start new with root as service owner
and now vibe is working.

The migration from the old sles11 is also done.

In any matter I have broken the MariaDb configuration. Service was dead
after system start and I had to reanimate with systemctl restart mysql.

So I followed
https://superuser.com/questions/384365/systemctl-enable-differs-from-systemctl-start-how

and wrote my own mysql.service. Additionally I moved mysql from
/etc/init.d to an other position for using with mysql.service

now all running fine.

HTH
Gotthard





Am 18.03.2019 um 09:47 schrieb Gotthard Anger:
> Hi,
>
> new server, new problem
>
> My first SLES 15 server was installed by coworker.
> Small installation w/o packages (just ssh, I had to add vnc manually).
>
> - mariadb-10.3.13-linux-systemd-x86_64.tar.gz installed by hand
> - added tk-32bit and tcl-32bit using yast
> - vibe user and group created
> now I could start the vibe installation procedure
> installer.log reports all ok
> - database created
> - database properties assigned
>
> Some show stopper: documentation recommends sles 15 or oes 18, but
> firewall configuration steps points to old sles 11 or sles 12.
>
> I disabled firewall completely ATM, because I have the command line
> configuration only.
>
> So I started the vibe service. Top reports the heavy cpu load by java.
> ps -eaf | grep teaming shows a running process.
>
> ss -4 -n -l reports no open ports on 80, 443, 8080 or 8443
>
> catalina.out contains no errors, eventually this warning:
> WARNING: An illegal reflective access operation has occurred
> WARNING: Illegal reflective access by org.dom4j.io.SAXContentHandler
> (file:/opt/novell/teaming/apache-tomcat/lib/ext/dom4j.jar) to method
> com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser$LocatorProxy.getEncoding()
>
>
> also appserver.log with warnings only
>
> what can I do?
>
> Gotthard
>
>
>
>
>



--
Gotthard Anger
Anwenderbetreuung Netzwerkadministration
Landeskirchenamt der EKM
gotthardanger@no-mx.forums.novell.com
https://forums.novell.com/member.php/35038-gotthardanger

Mails an diese Adresse werden nur nach vorheriger Ansage gelesen!
Mails for this address will only be read if you trigger me before.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.