Highlighted
Absent Member.
Absent Member.
1434 views

Vibe 3.4 Versioning + File locking issues

Dear all,

I've searched many Links in google and also the many Novell Forum Threads, but nothing answers my question. This confuses me because I can't imagine that only we have this problem.

Here our Issue:

We want to use Vibe as a File Management System with the feature of file versioning. So we imported our Files (Office files, PDFs) into our Vibe Server and started testing with the versioning.
What we noticed is that it is very easy to destroy the whole versioning of a file! You can reset a files version (f.e. 1.7) back to Version 1.0 with one simple click. It even deletes the whole version history of that file!

Let me try to explain:
We Have our Vibe Server (V.3.4) and many Clients (Win7) that have the Office 2007 Vibe Addin + Vibe desktop Client installed.

Now if a User opens a file (f.e. Word document) from the Vibe Server, with the Browser or with the office addin, makes changes and then wants to save them, he is asked if he wants to create a new version or overwrite it.
If you press "create new version" it does what is should, but if "overwrite it" is clicked, it will delete the whole versioning + history of the file...

This is not acceptable for us, because we need to keep the versioning of files for our documentation we create that belongs to files. It is no solution to change the rights to only read for all users. Because everyone needs to be able to create files, change them and delete if necessary.
Now to my confusion, are we the only company that has this requirement? I cant find anything regarding this problem...

A second Problem that we have is with the lock function in Vibe. You can lock a file but other users can easily open that file (f.e. over the web browser), make changes and save them... They are then the author of the file.
So the lock seems to be only a visual notification that it is "locked" from another user.


Can someone please help me on these issues?


Thanks and regards
Michael
0 Likes
3 Replies
Highlighted
Absent Member.
Absent Member.

Re: Vibe 3.4 Versioning + File locking issues

Sounds interesting ...
There's no quick answer yet.
I'll do some testing on your issues and get back to you.
Cheers
Erik
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Vibe 3.4 Versioning + File locking issues

Eric,

It would be great to get an update on this as we are using Vibe as a document management system as well - in addition to other features, but primarily for document management. We definitely have issues with the Locked File feature not being quite secure enough and we have version issues as described above, as well as the challenges of co-editing and loss of information from the overwrite.

Any insight, suggestions or news of updates would be appreciated.

Rob
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Vibe 3.4 Versioning + File locking issues

Hi all,

sorry for the late reply.

In the meantime I found out something interesting. The mechanic of the office Add-In seems to be broken (?) on some user clients! We compared a few Clients that have the office 2007 + Vibe Add-in installed, and we noticed a big difference in the updating mechanic!

On my Computer (= broken Add-in), when I open a File from the Vibe server, the first thing I noticed is, that my symbols (Dashboard, lock, refresh, etc.) in the Vibe Add-in are grayed out! I've checked the rights to that file, they are fine. It doesn't matter if I'm a user with admin rights or if I open it as THE Admin, same issue. Even the Dashboard to the right (in office), which should show me the owner, name, and version of the file, is missing. When I make a change and click "save" it opens the "save as" window.
On the other client (correct working Add-in), all the Vibe Add-in Symbol are usable, the dashboard is shown and when you press "save", it creates a new version. This is what I expect it to do.

If I use another Client with my credentials, it works fine! The strange thing is, the Add-in error only affects a handfull of clients... I've tryed everything to do a clean reinstallation of the Vibe Office Add-in but it doesn't fix the issue. I think that some files are not being deleted when doing the uninstallment.

I've checked the eventlog, it showes me the following message when opening files described above:

ERROR 2015-01-28 15:24:12,436 Novell.Collaboration.UX.Util.WindowSettings [1] - Unable to load window settings

System.Configuration.ConfigurationErrorsException: Fehler beim Laden des Anbietertyps: Novell.Collaboration.Core.Settings.AppDataSettingsProvider, Novell.Collaboration.Common, Version=1.0.1.302, Culture=neutral, PublicKeyToken=null.

bei System.Configuration.ApplicationSettingsBase.get_Initializer()

bei System.Configuration.ApplicationSettingsBase.CreateSetting(PropertyInfo propInfo)

bei System.Configuration.ApplicationSettingsBase.EnsureInitialized()

bei System.Configuration.ApplicationSettingsBase.get_Properties()

bei System.Configuration.ApplicationSettingsBase.Reload()

bei Novell.Collaboration.UX.Util.WindowSettings.RestoreSettings()



Regards

Michael
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.