Highlighted
TSchmauch Absent Member.
Absent Member.
1087 views

Vibe 3.4 and SSL offloading

We are attempting to put our vibe application servers behind a network load balancer (F5) and are running into a few issues trying to offload the ssl. Basically our plan is users come in on port 443, the f5 decrypts and sends the traffic to vibe on port 8080. Has anyone else had success doing this or something similar?

When we attempt this, when trying to login with either a directory or local account we are told invalid credentials. When I look at the catalina out, it basically says that a password is required. Is thisa supported configuration?

Thanks.
Tom
0 Likes
2 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Vibe 3.4 and SSL offloading

TSchmauch,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your problem been resolved? If not, you might try one of the following options:

- Visit http://support.novell.com and search the knowledgebase and/or check all
the other self support options and support programs available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.novell.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.novell.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your Novell Product Support Forums Team
http://forums.novell.com/

0 Likes
amfwills Absent Member.
Absent Member.

Re: Vibe 3.4 and SSL offloading

Hi,

I hit the same problem with a Filr install, but as the codebase is the same I imagine this fix will work for you.

The problem appears to be that the URLS embedded in the pages generated use absolute paths, as the server sees connections made via http the urls in the webpages generated are http://<filr-server>. I created an irule to replace http://servername with https://servername and now I can login successfully.

Alastair
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.