Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Saleschke Absent Member.
Absent Member.
1959 views

no Youtube videos in entries

When i try to embed a youtube video with tinymce-editor in vibe (expand the editor-toolbar and use the "embed video"-option in 2nd line of toolbar), i just get an empty entry (not empty at all - there is just a small "powered by youtube"-icon). Can't see/play the video/player. Any ideas?
0 Likes
6 Replies
rblehar Absent Member.
Absent Member.

Re: no Youtube videos in entries

Saleschke;2288380 wrote:
When i try to embed a youtube video with tinymce-editor in vibe (expand the editor-toolbar and use the "embed video"-option in 2nd line of toolbar), i just get an empty entry (not empty at all - there is just a small "powered by youtube"-icon). Can't see/play the video/player. Any ideas?


Sounds like a technical issue... I would open an SR with Novell.
0 Likes
e-ebell1 Absent Member.
Absent Member.

Re: no Youtube videos in entries

Saleschke;2288380 wrote:
When i try to embed a youtube video with tinymce-editor in vibe (expand the editor-toolbar and use the "embed video"-option in 2nd line of toolbar), i just get an empty entry (not empty at all - there is just a small "powered by youtube"-icon). Can't see/play the video/player. Any ideas?


Sounds like a known problem to me. Are you using Firefox?
0 Likes
Vibe_Library Absent Member.
Absent Member.

Re: no Youtube videos in entries

The YouTube video is recognized as an "unauthorized script" or "isn't secure" depending on which browser you are using. As such, the browser is blocking the content. You can unblock it by clicking on the shield icon in the address bar (in firefox it's to the left of the lock icon and in chrome it's on the right side of the address bar [next to the star icon]) Once you've unblocked it, you should see the YouTube video in Vibe above the "Powered by YouTube" graphic.
0 Likes
e-ebell1 Absent Member.
Absent Member.

Re: no Youtube videos in entries

Exactly! That's the main cause! Just as an example: Firefox changed it's behaviour regarding secure content not soooo long ago. That's why people still stumble across that issue. (after updating their browser)

by the way: It's good to see someone from Novell helping out in the forums after quite some time. Good to have you back 😉

Cheers
Erik
0 Likes
mcando Super Contributor.
Super Contributor.

Re: no Youtube videos in entries

Hi, I was reading your posted solution and I'd like to know how you did it. If you don't mind, can you give more details? I'm having the same problem with youtube videos and different browsers.
Thanks
ethancaleb;2290570 wrote:
Disabling direct HTML-editing doesn't make it any more secure . Maybe less scary for the average joe .
Anyway, I was able to add a YouTube video just by grabbing the embed URL and adding a Flash object with TinyMCE's own flash plugin and adding the width and height values.
0 Likes
Highlighted
ebelcher Absent Member.
Absent Member.

Re: no Youtube videos in entries

This is now a common problem on all browsers and I'd like to know if there is a way to use https for youtube instead of http. For our Vibe installations, we are always running https. So using YouTube https which is the default for Youtube these days anyway would solve a lot of problems. I've been able to edit a couple of files in Vibe to allow https to be entered in the editor, but I can't figure out how to get it to display correctly on the page. It simply displays the URL and doesn't invoke the YouTube player.

Anyone with good knowledge of the Vibe backend, able to assist me in this?
Thanks
Eric.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.