Problem:

Product Name: VisiBroker
Product Version: All
Platform/OS
Version: IBM AIX with IBM JDK 6

The lmadm does not start up and shows the error message "Unable to find a suitable Java VM in PATH".

Resolution:

There are several common reasons for this error message.
 
- The JDK installation may be broken
- The platform ( 32/64 bit ) does not match the VisiBroker version
- The configured path is wrong.
 
Besides these there is a known issue with IBM JDK 6, see IBM Reference# IZ87225. The symbolic links libjvm.a for jre/lib/ppc/j9vm/libjvm.so and jre/lib/ppc/classic/libjvm.so are missing. The recommended workaround is to manually create both links.