Highlighted
Super Contributor.
Super Contributor.
76 views

Bug Report: Communications with the remote debugger have been lost

Jump to solution

When I hover over an identifier that's being used in a string reference modification, "communications with the remote debugger have been lost":

Debugger - Communication lost.gif

 

In detail, this is the error message:Error Message.png

 

 Attached please find a sample project for reproducing the issue.

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Bug Report: Communications with the remote debugger have been lost

Jump to solution

Hi BlackKnight,

If you don't actually need to create a 64-bit executable it will be worth you trying debugging your application as 32-bit by changing the Platform Target back to x86 in the COBOL property page. Debugging a 32-bit ie x86 application does not need to use remote debugging as Visual Studio is an x86 executable itself.

I don't currently have 5.0 installed to verify your bug report as I am working on the forthcoming 6.0 product release but I can confirm that the problem is  already fixed in that.

Gael

View solution in original post

2 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Bug Report: Communications with the remote debugger have been lost

Jump to solution

Hi BlackKnight,

If you don't actually need to create a 64-bit executable it will be worth you trying debugging your application as 32-bit by changing the Platform Target back to x86 in the COBOL property page. Debugging a 32-bit ie x86 application does not need to use remote debugging as Visual Studio is an x86 executable itself.

I don't currently have 5.0 installed to verify your bug report as I am working on the forthcoming 6.0 product release but I can confirm that the problem is  already fixed in that.

Gael

View solution in original post

Highlighted
Super Contributor.
Super Contributor.

Re: Bug Report: Communications with the remote debugger have been lost

Jump to solution

Excellent! I'm very much looking forward to the 6.0 version then.

And I'd like to thank you for sharing this very interesting hint on x64 vs. x86 debugging with me.

Yes, you are right, for now I don't need x64 COBOL projects to compile or run. It's just become a vanilla habit to me.

Thanks! 👍

 

PS: I'm just trying to add a new avatar image here: 😊

Doofus Rick Avatar (small).png

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.