Absent Member.
Absent Member.
6028 views

Creating a Tab Delimited ASCII File

Jump to solution

[Migrated content. Thread originally posted on 02 June 2012]

Good Afternoon,

I am having a problem creating a Tab Delimited ASCII file. Here is an example:

I write the following ASCII record:
01 MEI-VT-LUCI-HEADER.
03 FILLER PIC X(06)
VALUE "TICKET".
03 FILLER PIC X(01)
VALUE X"09".
03 FILLER PIC X(01)
VALUE "A".
03 FILLER PIC X(01)
VALUE X"09".
03 FILLER PIC X(01)
VALUE "B".

The hex values should be:
54 49 43 4B 45 54 09 41 09 42 0D 0A

However when I look at the hex values in my resulting ASCII file it looks like:
54 49 43 4B 45 54 00 09 41 00 09 42 0D 0A

For some reason the system puts a X"00" before the X"09" in the ASCII file. If I Examine the record before I write it the values look correct.

Can anyone offer some advice ?

Thanks as always,
Bob
0 Likes
1 Solution

Accepted Solutions
Micro Focus Expert
Micro Focus Expert
This is the default behavior of the Micro Focus file handler when writing characters < X"20" into a line sequential file.

The file handler will insert a null character X"00" before each character that is non-printable so that it can read the same file back in without having the non-printable characters be misinterpreted as control characters like X"0D" or X"0A".

You can change this default behavior by placing the configuration option INSERTNULL=OFF in your extfh.cfg file.

You can also turn it off by using the callable library routine X"91" function 47.

View solution in original post

0 Likes
2 Replies
Micro Focus Expert
Micro Focus Expert
This is the default behavior of the Micro Focus file handler when writing characters < X"20" into a line sequential file.

The file handler will insert a null character X"00" before each character that is non-printable so that it can read the same file back in without having the non-printable characters be misinterpreted as control characters like X"0D" or X"0A".

You can change this default behavior by placing the configuration option INSERTNULL=OFF in your extfh.cfg file.

You can also turn it off by using the callable library routine X"91" function 47.

View solution in original post

0 Likes
Absent Member.
Absent Member.
Good Afternoon,

Thanks for your reply.

Bob
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.