Highlighted
Absent Member.
Absent Member.
2270 views

Decimal-point is comma not working properly

Hi, guys!
Living in a country that uses comma as a decimal point (1.000,00), I found a bug in the decimal-point is comma declaration.
After using a mask to accept input:

w-Number   PIC  9(02)V9(02)
w-Number-e      PIC  Z9.99


It displays "0,00" but it ignores the Z, and after moving the mask to the proper variable, it continues to have the default value:

move w-Number-e to w-Number.

0 Likes
1 Reply
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: Decimal-point is comma not working properly

I am not sure I understand. If you are using decimal-point is comma then your pic should be Z9,99 instead of Z9.99.

Can you please post the entire code snippet and tell me what the results are that you see?

Is this a native code project or a managed code project?

Thanks.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.