Highlighted
Absent Member.
Absent Member.
1732 views

How to Hide and Protect a input field on screen with ACCEPT

Jump to solution

Hello,

 

I am trying to use the same screen section for several purposes. In a case all input fields must be available to the user, and in another case some fields must be protected and not visible. Of course the change in the field attribute has to be done at run time. 

I tried to play around with the ACCEPT CONTROL clause, I simply move "PROTECT" to a variable previously linked to the CONTROL clause in the SCREEN SECTION. 

Result: The field is effectively protected but the cursor stop on it when I hit tab from the previous field!!! 

Is somebody knows if there is a way to avoid the cursor to pause on it? 

Cheers

PascalUK

0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.
Absent Member.

RE: How to Hide and Protect a input field on screen with ACCEPT

Jump to solution

I found a solution to skip a protected field. In ADIS configuration file you can change a setting to do exactly that. The parameter is in "Configurable ACCEPT/DISPLAY Options", Option "30. Control of whether concealed fields are skipped".

More information about ADIS configuration file here : https://supportline.microfocus.com/documentation/books/nx30books/ciadcfcn.htm  

Cheers

PascalUK

View solution in original post

0 Likes
4 Replies
Highlighted
Absent Member.
Absent Member.

RE: How to Hide and Protect a input field on screen with ACCEPT

Jump to solution

In fact this is not the move "PROTECT" who make the field not visible... It's the fore/background color that I both set to 0 (black/black). I can not find in the documentation how to make the field hidden and stop the cursor to pause on it. 

Cheers

PascalUK

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: How to Hide and Protect a input field on screen with ACCEPT

Jump to solution
I can find no way to do what you wish with the same screen definition. The PROTECT simply makes a field so that you cannot enter data into it. It does not control the ability to tab to the field.

I would recommend that you create a second screen that has the attributes set that are required and use it for your altered screen handling.

Somebody else may have a better approach to solving this issue so I will let them chime in...
0 Likes
Highlighted
Absent Member.
Absent Member.

RE: How to Hide and Protect a input field on screen with ACCEPT

Jump to solution

That exactly what I was thinking to do, but it is pretty ugly (no offence).

I have the same issue when I have a list of items on the screen (occurs). Sometime the screen is full (all occursed lines hold data), but when the bottom lines are empty, my users can still go with the cursor on an empty line (see line 4 on column Act in picture). It is ugly and not user friendly.  

Cheers

PascalUK

0 Likes
Highlighted
Absent Member.
Absent Member.

RE: How to Hide and Protect a input field on screen with ACCEPT

Jump to solution

I found a solution to skip a protected field. In ADIS configuration file you can change a setting to do exactly that. The parameter is in "Configurable ACCEPT/DISPLAY Options", Option "30. Control of whether concealed fields are skipped".

More information about ADIS configuration file here : https://supportline.microfocus.com/documentation/books/nx30books/ciadcfcn.htm  

Cheers

PascalUK

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.