jvinin Absent Member.
Absent Member.
3429 views

Issue is still the same...

Jump to solution

[Migrated content. Thread originally posted on 22 March 2011]

Hi Chris,

Thanks for respond. Just followed your suggestions and received the same messages:

os.init:
os.init.windows:
os.init.unix:
init:
init.New_Configuration:

build:
os.init:
os.init.windows:
os.init.unix:

init:
pre.build.cfg.New_Configuration:

os.init:
os.init.windows:
os.init.unix:

init:
cfg.New_Configuration:
[cobol]
[cobol] Compiling Program1.cbl...
[cobol] * Invalid filename
[cobol] Unable to open response file
[cobol] Compilation complete with 0 errors, 0 warnings, 0 notices and an exit code of 538,976,288
[cobollink] Linking testproject.exe...
[cobollink] Micro Focus COBOL - CBLLINK utility
[cobollink] Version 1.2.0.156 Copyright (C) 1984-2010 Micro Focus (IP) Limited.
[cobollink]
[cobollink] ERROR: (1) Cannot open file : Program1.obj
[cobollink] ERROR: (6) No public symbols found. No object file generated
[cobollink] Link complete with errors
[cobollink]


BUILD FAILED
Build finished with 1 errors, 0 warnings, 0 notices and a maximum exit code of 538,976,288

C:\@D_Drive\Visual_2010\testproject\.cobolBuild:140: Build errors have occurred

Total time: 1 second

So I am still their. Do not know why I am getting message "* Invalid filename"?
If I am running "Clean..." I am getteng message "BUILD SUCCESSFULL" but cannot see any
.obj and .exe files. May be I have to specify it somewhere like in NetExpress?

Thank you
0 Likes
1 Solution

Accepted Solutions
Micro Focus Expert
Micro Focus Expert

RE: Issue is still the same...

Jump to solution
The problem is because of the @ character in the workspace name.
Try it as C:\TestProject instead of C:\@TestProject and it will work fine.

I believe that the @ character is being intepreted as a response file to the cobol and cbllink command as this is how they are specified.

Example:

cobol @respfile.rsp
0 Likes
6 Replies
alex_turner Absent Member.
Absent Member.

RE: Issue is still the same...

Jump to solution
Hi,

Is there any chance you could post the files you have in your project - just the names if you want.

It seems to me that something is incorrectly configured. It is as though the compiler is being asked to compile FILEAID.cbl and cannot find it. cbllink can then not find the object files because the compiler could not find the source file.

Best wishes - AJ

Dr Alexnander J Turner
Software Systems Developer Senior Principal
0 Likes
jvinin Absent Member.
Absent Member.

RE: Issue is still the same...

Jump to solution
Hi Alex,

Thanks for reply.
Unfortunately there is no option to attach file or place print screen.
I created (as Chris advised) to create testproject with MF provided Program1.cbl
Added Display statement and saved.
This project located on my PC - C:\@D_Drive\Visual_2010\testproject.
Inside of testproject directory are: folder - New_Configuration.bin
file - .cobolBuild
file - .cobolProj
file - .project
file - Program1.cbl (source program)
Here is the source after I added "Display" statement:

program-id. Program1 as "Program1".

environment division.
configuration section.

data division.
working-storage section.

procedure division.

Display "I am here".

goback.

end program Program1.

Obviously something causing not to create .obj file... Cannot find what

Thank you
0 Likes
Micro Focus Expert
Micro Focus Expert

RE: Issue is still the same...

Jump to solution
Is this a folder on a mapped drive: PC - C:\@D_Drive\Visual_2010\testproject.

Can you please try to create a new workspace on your C drive as follows:

In IDE select File->Switch Workspace->Other and create a simple workspace name like C:\testvc and click OK.
Eclipse will restart.

Add a new project and new program as you did before.
Does it build now?
0 Likes
jvinin Absent Member.
Absent Member.

RE: Issue is still the same...

Jump to solution
Alex,
Thanks for reply.
Here is what I did.
Created new work space as C:\@TestProject. Created new project - C:\@TestProject\TestProject.
Created program inside of the project - Program1.cbl
After build got the same errors:
cfg.New_Configuration:
[cobol]
[cobol] Compiling Program1.cbl...
[cobol] * Invalid filename
[cobol] Unable to open response file
[cobol] Compilation complete with 0 errors, 0 warnings, 0 notices and an exit code of 538,976,288
[cobollink] Linking TestProject.exe...
[cobollink] Micro Focus COBOL - CBLLINK utility
[cobollink] Version 1.2.0.156 Copyright (C) 1984-2010 Micro Focus (IP) Limited.
[cobollink]
[cobollink] ERROR: (1) Cannot open file : Program1.obj
[cobollink] ERROR: (6) No public symbols found. No object file generated
[cobollink] Link complete with errors
[cobollink]


BUILD FAILED
Build finished with 1 errors, 0 warnings, 0 notices and a maximum exit code of 538,976,288

C:\@TestProject\TestProject\.cobolBuild:140: Build errors have occurred

Total time: 0 seconds

Do not know what is wrong with file name. Probably this reason effect creating .obj file

Thanks
0 Likes
Micro Focus Expert
Micro Focus Expert

RE: Issue is still the same...

Jump to solution
The problem is because of the @ character in the workspace name.
Try it as C:\TestProject instead of C:\@TestProject and it will work fine.

I believe that the @ character is being intepreted as a response file to the cobol and cbllink command as this is how they are specified.

Example:

cobol @respfile.rsp
0 Likes
jvinin Absent Member.
Absent Member.

RE: Issue is still the same...

Jump to solution
Chris,
Thanks a lot. It worked.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.