Highlighted
Super Contributor.
Super Contributor.
1407 views

Perde as referências

Tenho um projeto em usando o Visual Studio 2015 e esta ocorrendo o mesmo problema que acontecia com as outras versões ele perde as referências, ai temos que refazer todas as ligações isso e problema do Visual Studio ou do Visual Cobol?

0 Likes
4 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: Perde as referências

Can you please provide more detail?

What type of references are you referring to that are getting lost and when are they disappearing? Are these references to .NET assemblies, 3rd party assemblies or to your own assemblies? If you are using managed code projects then it is recommended that you use direct project references instead of browsing for a specific assembly and adding it as a reference.

Thanks

0 Likes
Highlighted
Super Contributor.
Super Contributor.

RE: Perde as referências

Todas as referências nos eventos, tanto de botões quanto de grids, tudo tem que ser refeito isso já acontecia na versão 2013 e agora nesta também acontece. Não usamos nada além do Visual Studio e Visual Cobol. Não temos uma ordem ou sequencia de como as coisas acontecem simplesmente os eventos dos botões somem, os parágrafos continuam existindo mas sua ligação com o botão some.

Obrigado

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: Perde as referências

Is this a Windows Forms application? If it is then all events that are created in the Properties dialog are saved to the designer.cbl code-behind file. Are you saying that the event hookup code is being removed from this source file perhaps by being overridden by a subsequent save?

I have seen this type of behavior in very old Visual COBOL product releases but have not experienced it in any recent versions.

I would recommend that you open up a support incident with Customer Care for this as we would need to try to investigate the steps to reproducing the problem in-house.

0 Likes
Highlighted
Super Contributor.
Super Contributor.

RE: Perde as referências

É Windows Forms e só perde a ligação. Veja a imagem, ele perde esta ligação, já abrir uma chamada a muito tempo atrás mas não conseguimos replicar o problema ai o suporte não tem como resolver. Mas obrigado mais uma vez pela sua ajuda.

Abraços

  

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.