Highlighted
Super Contributor.
Super Contributor.
1406 views

Setting cobol tabs

Jump to solution

Is there a way to set specific tabs is Visual Cobol?  Such as at 7, 8, 12, and 72.  Under Tools/Options/Text editor/Micro focus cobol, the tabs button does not seem to give choices like that.

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: Setting cobol tabs

Jump to solution

There are some settings that you can try that affects this behavior. Look under Tool-->Options-->Text Editor-->Micro Focus COBOL-->Margins and ensure that the Home Key and End key navigation option is on.

You are using SOURCEFORMAT"FIXED" in your project correct? You can see the margin starting in column 73?

View solution in original post

0 Likes
6 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: Setting cobol tabs

Jump to solution

This is what COBOL Smart Edit mode does for you. You can turn this on by toggling the Smart Edit icon on the toolbar but instead of using the tab key you use the Home and End keys to move between stop points.

0 Likes
Highlighted
Super Contributor.
Super Contributor.

RE: Setting cobol tabs

Jump to solution

Just tried this.  Works okay for the Home key, which stopped at col 7, 8, and 12, but the End key just brings me to the end of a text line, not to column 72,

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: Setting cobol tabs

Jump to solution

The End key will take you first to the end of the text line and then if you press again to column 72.

0 Likes
Highlighted
Super Contributor.
Super Contributor.

RE: Setting cobol tabs

Jump to solution

Hi Chris,

Well, I tried that, but the End key won't budge past the end of the text line.  Maybe there is a setting somewhere I need to change.

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: Setting cobol tabs

Jump to solution

There are some settings that you can try that affects this behavior. Look under Tool-->Options-->Text Editor-->Micro Focus COBOL-->Margins and ensure that the Home Key and End key navigation option is on.

You are using SOURCEFORMAT"FIXED" in your project correct? You can see the margin starting in column 73?

View solution in original post

0 Likes
Highlighted
Super Contributor.
Super Contributor.

RE: Setting cobol tabs

Jump to solution

Never mind, think I got it to go to 72 but changing something in the options/edit/microfocus/margins.

Thanks, Chris!

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.