Commodore
Commodore
390 views

Tabs arent' replaced with spaces when pasted

Jump to solution

If I copy the following text from Notepad++ ...

[tab][space[space]***********************************************************
[tab][space[space]*
[tab][space[space][space]V000-VALIDATE SECTION.
[tab][space[space]*
[tab][space[space]***********************************************************

and paste it into the Text Editor in Visual COBOL, the tabs are kept despite having selected "Insert spaces" in Tools - Options - Text Editor - Micro Focus COBOL - Tabs and having checked "Format pasted code" in Tools - Options - Text Editor - Micro Focus COBOL - Formatting.

If I paste the same text into Net Express the tabs are replaced with spaces.

In both Visual COBOL and Net Express the cursor was located at position 1 when I pasted.

I'm using Visual Studio 2019 and Visual COBOL 5.0 with the latest updates. The project type is an INT/GNT project.

 

0 Likes
1 Solution

Accepted Solutions
Commodore
Commodore

Hi, @Jens Forsberg,

I can confirm that there's an issue with Visual COBOL v5 reading user settings:

User settings are not used by Visual COBOL until you manually open each settings panel under Tools > Options > Text Editor > Micro Focus COBOL individually.

Here's an animation, depicting the issue you mentioned:

Settings not read.gif

 

That's quite tedious, but Ted John, who's a member of the product team, may have confirmed that this will be solved with version 6.

This thread deals with the same issue, yet a different option setting panel.

View solution in original post

2 Replies
Commodore
Commodore

UPDATE: This is strange indeed. I gave it another try and now the tabs got replaced by spaces ... But now the asterisks got misplaced. The first line looks like this:

[space][space][space][space][space][space][space][space][space][space]*********

which resulted in a design-time error.

0 Likes
Commodore
Commodore

Hi, @Jens Forsberg,

I can confirm that there's an issue with Visual COBOL v5 reading user settings:

User settings are not used by Visual COBOL until you manually open each settings panel under Tools > Options > Text Editor > Micro Focus COBOL individually.

Here's an animation, depicting the issue you mentioned:

Settings not read.gif

 

That's quite tedious, but Ted John, who's a member of the product team, may have confirmed that this will be solved with version 6.

This thread deals with the same issue, yet a different option setting panel.

View solution in original post

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.