CBL_DEBUGBREAK call fails in Visual COBOL

CBL_DEBUGBREAK call fails in Visual COBOL

Problem:

Customer is using Visual COBOL 2.1 and has installed the Visual Studio 2010 Shell IDE that is provided with Visual COBOL.

When his program calls "CBL_DEBUGBREAK" it should launch the Visual Studio IDE for debugging but it is failing to launch.

What is the problem?

Resolution:

This is a known issue that occurs when using the Visual Studio 2010 Shell on a 64-bit Windows system.
Microsoft did not package the required JIT Debugging executables in the Shell version of Visual Studio 2010 when installed on a 64-bit system.

This problem does not occur on a 32-bit Windows system or if a Visual Studio 2010 Professional or higher product is being used.

It also does not occur with the Visual Studio 2012 Shell.

So customer has options of installing Visual COBOL for Visual Studio 2012 or to upgrade their Visual Studio 2010 product to Professional or higher.

 

 

DISCLAIMER:

Some content on Community Tips & Information pages is not officially supported by Micro Focus. Please refer to our Terms of Use for more detail.
Top Contributors
Version history
Revision #:
1 of 1
Last update:
‎2013-05-30 11:10
Updated by:
 
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.