Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE

Content is cut after a low-value when using a tool-tip during a debug session

Content is cut after a low-value when using a tool-tip during a debug session

Problem:

There is an issue in tool-tip during a debug session when a variable contains a low-value. In this case, the shown content is cut after the low-value and you are not able to see the whole content. This also happens in the auto-window and the monitor-window.

In Net Express the content was fully shown.

Resolution:

This behaviour is expected in Visual Studio.

The tool-tip displays the value of the item as a string and strings are terminated by a null byte. If you hover over a buffer in a C/C++ program containing a null byte you see exactly the same behaviour. 

The tool-tip has a magnifying glass and if you click the arrow next to it and select the Text Visualizer the entire content of the item is displayed when debugging native code, with the null byte shown as '.'.

DISCLAIMER:

Some content on Community Tips & Information pages is not officially supported by Micro Focus. Please refer to our Terms of Use for more detail.
Top Contributors
Version history
Revision #:
1 of 1
Last update:
‎2017-10-17 09:21
Updated by:
 
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.